After a clean install of Ubuntu 16.04 LTS, I am experiencing very slow shutdowns compared with 15.10. There seems to be one of two processes that hang upon shutdown. Startup is not affected at all. When pressing (esc) the following are shown. Either:

"Stopping thermal daemon services" hangs, or "A stop job is running for remote CUPS printers available locally", before a timer to 1 min 30 seconds is up, after which the machine finally shuts down.

Are there any other people experiencing this? This is most odd. What could be the reasons behind these two hangs?

  • Please check my recent solution as this bug has been fixed with cups-filters v1.11.4-1 yet not released in the Ubuntu 16.04 official repository. Hope this helps. – Xiaodong Qi Mar 25 '17 at 5:52

I found that the daemon responsible for the CUPS remote printers is the cups-browsed service.

When shuting down, it has a time out of 1m 30s. Stopping this service cause the shutdown process to take only few seconds.

So, I disabled it using this command line on Ubuntu Gnome 16.04:

sudo systemctl disable cups-browsed.service

And my shutdown process ends in a few seconds.

Idea comes from this post: https://askubuntu.com/a/369122

  • This worked for my non-clean 16.04 install! :-) – jvriesem Jul 1 '16 at 16:15
  • This was happening for a while, tested a few things like apport on/off, etc. This actually worked, thanks! – xamox Aug 12 '16 at 1:53
  • 1
    This works only for the next shutdown. Doesn't persist. – Rajesh Paul Aug 13 '16 at 21:09
  • I think disabling it altogether is not the solution if you really need this service. In my opinion the solution is given in unhammer's answer. – Ali Jun 22 '17 at 15:18
  • This is working on 17.10 – BenR Mar 8 at 18:21

If you depend on network printers, you could simply make systemd a bit more aggressive in stopping the process. By default, it waits up to 1m30s before forcefully shutting things down, but you can just do

$ sudo systemctl edit cups-browsed.service 

and enter

[Service]
TimeoutStopSec=10

to set the timeout down to 10. Then a

$ sudo systemctl daemon-reload 

should make it take effect (or restart your computer).

This works great for me at least.

EDIT: According to Xiaodong Qi's answer, cups-filters 1.11.4 has a fix for this, so upgrading to 17.04 Zesty (which has cups-filters 1.13.4) should be the simplest fix.

  • I think 2 seconds is enough – pylover Aug 11 '16 at 20:43
  • Probably; I have it set to 5 myself. It depends on how conservative you want to be (e.g. if you click "print" and immediately shut down, who knows if that SIGKILL could drop a slow print job – OTOH most people might expect to have to wait a bit with shutting down after clicking print). – unhammer Aug 12 '16 at 6:44
  • This works only for the next shutdown. Doesn't persist. – Rajesh Paul Aug 13 '16 at 21:09
  • Rajesh Paul, that's odd; does cat /etc/systemd/system/cups-browsed.service.d/override.conf show the same contents as above? Is this also on Ubuntu 16.04? – unhammer Aug 14 '16 at 6:40
  • 2
    Note about the "EDIT", this still happens in Zesty (at least on my dell XPS) – ben Jul 5 '17 at 7:52

I have got the same Problem. It occurred after clean install Ubuntu 16.04. Finally I figured out, after lots of troubleshooting, that (after disable the Ubuntu boot splash screen) a certain stop-job was running that made the shutdown slow. (Thanks to Alex!) Then I got this error report:

a stop job is running for make remote cups printers available locally

Then I tried this:

sudo systemctl stop cups-browsed.service
sudo systemctl disable cups-browsed.service

To verify:

sudo systemctl status cups-browsed
sudo systemctl is-enabled cups-browsed

and it finally worked! Shutdown was now as good and fast as ever. (You can find this troubleshooting on: "The Annoying Cups Browsed" at the ec-cwang´s Blog!)

This might be important for those this solution is not helpful: How to find out your running stop jobs, just look up: "How do I disable the boot splash screen" on Ask Ubuntu. Then, if you start Ubuntu you get the typical Linux running command signs. If you shut Ubuntu down, mention the output. It shows you at the end what kind of stop job slows down your shutdown procedure.

  • Thank you very much, I will try this when I have upgraded again (currently downgraded back to 15.10 due to other issues) – ijustupdatednowwhat Apr 29 '16 at 8:05
  • very likely the solution, since .. stop cups-browsed.service takes ages in the console. – Blauhirn Apr 24 '17 at 12:37
  • I think disabling it altogether is not the solution if you really need this service. In my opinion the solution is given in unhammer's answer. – Ali Jun 22 '17 at 15:18

I had a similar problem. After checking everything, I found out that if uncheck "enable wireless" (right button on wifi icon), and restart, it takes 5 seconds. If i leave wireless active shutdown takes about 1 minute.

I have a USB wifi adapter TP-LINK. Hope it helps you.

Almost identical problem after clean update from 15.10. I have finetuned different programs/properties including made an attemmpt installing my wifi cup printer. Most seems to work, but shutdown takes more then 3 minutes. Pressing f12 shows end endless textloop: OK Start showing plymouth reboot screen OK Stopped thermal daemon service. Can I somehow get a log of the shutdown proces? 2: SOLVED. After installing the printer correctly everything works.

I experienced a similar issue. Turned out to be caused by Private Internet Access client. I had enabled "Start application at login". After disabling this feature, shutdown is almost instant.

Up until now, this bug should be fixed upon the recent release of the CUPS-filters (v1.11.4+) package related to two issues of CUPS--this one and this one. It requires to install CUPS-filters version 1.11.4-1 or above according to this discussion. However, it requires CUPS version 2.2.0+, and in fact the working CUPS-filters and CUPS-core versions haven't been released in the Ubuntu 16.04 repository so far. If you are still having this issue, you might want to try downloading the corresponding CUPS-filters and its dependencies (including libcups2, cups-ipp-utils and others) from the Zesty's repository (for example, with this version) and install the downloaded deb packages using the dpkg command like:

 sudo dpkg -i ~/Downloads/libcups2_2.2.2-1ubuntu1_amd64.deb 
 sudo dpkg -i ~/Downloads/cups-ipp-utils_2.2.2-1ubuntu1_amd64.deb 
 sudo dpkg -i ~/Downloads/cups-filters-core-drivers_1.13.4-1ubuntu1_amd64.deb 
 sudo dpkg -i ~/Downloads/libcupsfilters1_1.13.4-1ubuntu1_amd64.deb 
 sudo dpkg -i ~/Downloads/cups-filters_1.13.4-1ubuntu1_amd64.deb 

I am only giving command lines as a template for you to install the dependencies and the CUPS-filters deb packages. Feel free to download the package from elsewhere with a different version (has to be ~>1.11.4 for CUPS-filters). You may find you would need to install a lot of other dependencies and fix the incompatibility problems with the corresponding i386 and amd64 versions of those packages in your case. You should download packages with the same version number for all dependent packages. For instance, all cups related packages as linked should be chosen to have the same version number 2.2.2-1ubuntu1 or otherwise. Then those related binary packages should be downloaded from the Binary Packages section from the same page. If you find there are two package which cannot be configured simultaneously, don't worry and you should be able to configure them automatically using sudo apt update && sudo apt upgrade after you install all other packages.

Alternatively, you can temporarily change your update source list to Zesty (Ubuntu 17.04) or most recent distribute and then install required CUPS packages using sudo apt update && sudo apt install PACKAGE where you should replace the keyword PACKAGE for the name of packages you want to upgrade to the latest version. Don't forget to change the source list back after this partial upgrade. But this method may make you break other things if you are not doing it correctly.

This is how I fixed this problem on my Ubuntu 16.04. YMMV.

PS:

  1. If your printing jobs cannot be stopped, you can use cancel -a to cancel all printing jobs.

  2. If you still encounter this issue after the last fix on Ubuntu, please report this bug here directly to developers. They will look into this issue more closely.

  • Does that mean the bug is no more in 17.04, making these workarounds unnecessary? – unhammer May 24 '17 at 7:59
  • 1
    I haven't tried 17.04, but if you find the version number of CUPS-filter is newer than 1.11.4, the problem with CUPS should be fixed and then you don't need to go over the workaround. – Xiaodong Qi May 25 '17 at 6:07
  • packages.ubuntu.com/zesty/cups-filters seems that way =D – unhammer May 25 '17 at 13:50
  • According to cups-browsed causes shutdown hang/delay in Ubuntu 16.04 has been fixed by now in 16.04, yet it still hangs. I double checked, and I have the "fixed" package install. Weird. In my opinion the solution is given in unhammer's answer; that helped me. – Ali Jun 22 '17 at 15:21
  • My personal guess is there might have been multiple issue with CUPS, or the fix doesn't really fix the problem for a broader case. The fixed bug is to shut down the service once the computer verified the printing service based on my understanding. @unhammer's answer basically set up a short shutdowntime if the service is still running when shutting down the computer. I'll report this to developers. Thanks! – Xiaodong Qi Jul 12 '17 at 19:41

protected by Community Sep 1 '16 at 19:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.