0

I have set up xrdp on my ubuntu server 15.10, with mate desktop environment and it all works fine and dandy. Except for when I enable UFW. I have the following ports allowed all tcp

2222 (ssh)

3389 (what I believe is for xrdp)

5910 (because xrdp kept trying to use that port, don't know if I need that open)

now if I disable ufw, then login to the remote desktop, then close it, and re enable ufw, I can then re open the remote desktop. Once I reboot the server though I find myself in the same predicament.

/etc/xrdp/xrdp.ini

[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3389
crypt_level=high
channel_code=1
max_bpp=24

[xrdp1]
name=sesman-Xvnc
lib=libvnc.so
username=ask
password=ask
ip=127.0.0.1
port=ask5910

I have set the port to ask5910 although I would like to set it to just a specific port.

I have searched everywhere, and all I can find is allow ssh and 3389/tcp through ufw, and I have done that. So what am I doing wrong? Is there anyway I can use xrdp as soon as my system boots without having to disable my firewall?

  • i have figured out if i reboot (ufw is enabled) open remote desktop, and enter port -1 (let it fail) then log in to port 5910 it works, is there a way i can make it so i dont have to do port -1 first? – your mom Apr 23 '16 at 2:16
0

Since Ubuntu 14.10, the xrdp package provided by Ubuntu (Ubuntu repositories) allow you to reconnect to the same session.

firewall wise, you should only need the port 3389 as the xrdp software is acting as a proxy. When you connect to port 3389, in your xrdp.ini file, you can see that additional connection is done through the ip 127.0.0.1 (itself)

We have tested the following

  1. Install xrdp (from ubuntu repository) (sudo apt-get install xrdp)
  2. Install mate-desktop as alternate desktop
  3. enable your firewall
  4. for xrdp, allow incoming traffic for 3389

at this stage, we are able to perform a remote desktop connection to ubuntu. we can disconnect and reconnect to the same session while the firewall is enabled We can reboot the server and connect via xrdp while firewall is enabled...

So our recommendation, try to install xrdp as default and you should be good to go

Hope this help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.