4

I have an onboard Intel graphics card, and a ATI Radeon accelerator in hybrid graphics. In 1404 LTS, my previous version, I used ATI's catalyst driver, and I could switch betweeen the graphics system in it.

Now, my 16.04 LTS is using onboard Intel as the default VGA controller, and lists ATI as well as display controler, but not in use. Additional drivers don't provide anything. So is AMDGPU being used, or is ATI disabled?

lspci -nnk | grep VGA -A1:

00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)
    Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]

lspci:

04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev ff)
4

I had to update to the the mainline kernel 4.6.3 before DRI_PRIME=1 glxinfo | grep "OpenGL renderer" returned my AMD card. I am on a thinkpad s531 with an i7 processor and a Radeon HD8600.

I followed this guide to update the kernel.

As described here you can then use eg. DRI_PRIME=1 blender to run a program with the AMD GPU.

2

Since you have the hybrid graphics and the Intel controller is present, your active card will be the Intel one. Support for AMD on 16.04 is, well, none. And there are no plans at this point to support AMD cards unfortunately (I also have a hybrid one). There is also no way to install Catalyst onto 16.04 either, and even if you manage to hack it in, it will likely break things.

For now you can do as other have, including myself, and just disable it. This is to preserve a bit of power when running on battery, but mainly (for myself) it's to keep my laptop running cooler.

Here's how I disabled my AMD card (this method is using the default lightdm Display Manager for Unity)

Note: In my examples I use "username". Replace that with your actual user name.

Create a script, place it somewhere in your home folder.

Mine is /home/username/scripts/radeonoff

In this script, put the following

chown username /sys/kernel/debug
chown username /sys/kernel/debug/vgaswitcheroo/switch
echo DIS > /sys/kernel/debug/vgaswitcheroo/switch
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Save it and make the file executable either using the properties tab in the gui, or in terminal with chmod 755 radeonoff

Now edit this file as sudo using your fav editor : /etc/lightdm/lightdm.conf

And add this line: session-setup-script = /home/username/scripts/radeonoff and save.

Now when you reboot, after you login, your radeon card should be disabled.

Verify this in terminal by running sudo cat /sys/kernel/debug/vgaswitcheroo/switch

You should see an output with a line like this 0:DIS: :Off:0000:01:00.0. And what you're looking for is the line that has "DIS" to also show ":Off".

  • Will try, thanks! Hopefully it's easy to revert changes as well, once it becomes available? – Mookey May 26 '16 at 17:13
  • @Mookey No problem! Yes, if a driver becomes available, remove the line from lightdm.conf and delete the script. Easy to undo. – Dorian May 26 '16 at 17:24
  • OK, so I've tried this but I get system freeze when I try it at kernel 4.4.0.22, which was a regular software update build. I've followed the steps, and still it happens. At this kernel, the DIS is not off and I have higher CPU activity and temp and battery is reduced. However, at 4.4.0.21, Radeon seems to be disabled by default, leaving 1:DIS: :DynOff:0000:04:00.0. – Mookey May 26 '16 at 21:49
  • It's either system freeze, or almost 100% CPU consumption and fan, when using it. :( Also, some errors when I try to reboot after exiting GUI. I guess I'm stuck at 4.4.0.21. – Mookey May 26 '16 at 21:59
  • Hmm, that's odd. You could try installing the 4.6 Kernel. That's what I'm using and my radeon card stays off with the script I posted. Before updating the kernel, try booting again, press "e" at the grub menu, and after quiet splash add radeon.runpm=0 then press F10 to boot and see what happens then. – Dorian May 26 '16 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.