9

I've just updated my ubuntu 15 to ubuntu 16. Now, every time I shutdown, the computer reboots after a few seconds! I've already googled for solutions but nothing worked. My computer is a HP probook 4540s.

Thank you

EDIT: One more piece of information: when I restart instead of shutting down, I can no longer access the internet (via wi-fi). Also, I can get my computer to shutdown without rebooting if a press ( a long time) the (hardware) power button.

3

Try to turn off your wifi from shortcut button for wifi / or from settings and your pc will not start itself.

  • Weirdly, this worked for me even though I connect to the internet over ethernet (there is still a WiFi module present though) – Anake Jul 18 '16 at 7:23
2

I had this problem once with a HP Probook 840 or something of the sort. You should try disabling "Wake on LAN" or "Wake on WLAN" in your BIOS.

  • 1
    I already tried that. However, I found no such thing in my BIOS... – Xico Sim Apr 27 '16 at 13:45
  • @XicoSim, You said you have an HP. Look in the advanced menu for "built-in device options" for "wake on LAN". – H2ONaCl Feb 19 '18 at 17:08
  • worked for me on a Lenovo M73 Tiny with Ubuntu 19.04 – adamc May 22 at 8:18
1

A workaround I am using is to push the power button while on the grub screen. Also there is a related bug at ubuntu-mate bug tracker.

EDIT (2017_02_14): Some time ago I've found the same problem reported in a bug report for ubuntu-mate (as this is what I've used).

And just recently the bug seems to be SOLVED after the last kernel upgrade!!! I am not very sure about though. Need additional testing. But today with all the rest in the setup unchanged the laptop (HP probook) started to poweroff normally.

Current kernel is:

$ uname -a
Linux uhp 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

What about the other affected people?

PS seems to be similar to THIS thread

  • Still happens to me. Is it safe to use that workaround? – Soap Apr 18 '17 at 22:57
  • I have this problem with an ASUS F751LDV laptop. I use openmediavault (debian). If I shutdown it restarts. Only way it does not do this is by enabling a power saving option in BIOS that as a side effect does prevent this. But then WOL does not work of course. I also had this problem with pressing the physical power button. But it is not always the case. – Ben Apr 8 at 9:26
1

Same issue happens with me. The same sympthom happed with standard 16.04 installation and the current Ubuntu Mate:

gnagy@hp-pb-4340s:~$ uname -a
Linux hp-pb-4340s 4.8.0-46-generic #49~16.04.1-Ubuntu SMP Fri Mar 31 14:51:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

It's important that it did not happen immediately. Couple of weeks passed - roughly a month - then this started to come again and again.

What worked for me as a workaround: - disable networking before you turn off the machine - reinstall

Just to confirm that it is still an issue.

0

Don't know if this is a solution for other people, but if you have a mouse or something on an usb port: change the port.

I had a similiar problem: fresh install 16.04 ubuntu mate 64, not even one other thing installed and it took my pc nearly two or three minutes to shutdown and after that it immediately rebooted. No problems on Win7. I couldn't find a solution, not with grub updates/changes, bios or whatever. Looked up a lot of boards for answers, nothing worked ...

Changed the mouse, same effect; changed the usb port: worked. Shutdown now takes seconds and no reboot after.

I have no idea why - if this is a problem on my side or on linux (I'm absolutely no techie), but I thought, I should tell people, if it can help anyhow ...

  • 1
    I've tried with no mouse or keyboard plugged in, but it still happens... – Xico Sim Apr 28 '16 at 20:37
  • 1
    Some people mentioned turning off USB 3.0 legacy mode in BIOS. Others added acpi=force to grub menu. Which for myself was ab bad idea cuz the PC then takes ages to boot. Others tried: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios" others had reboot=pci which I cannot test right now cuz I have a new pc and it is working now for me. Hope this was of help. – Peterling Dec 5 '16 at 21:09
0

The solution for me was updating the grub (Ubuntu 16.04).

sudo update-grub

I found this solution here: Fix Shutdown does not power off computer in Ubuntu 14.04

  • This command updates the GRUB configuration, however if you don't edit any GRUB settings file, this command alone will hardly solve anything. Some people suggest adding acpi=force to the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub -- in this case, an invocation of update-grub will be indeed needed after editing the file. – Ale Sep 21 '18 at 22:53
0

I had same issue with my custom build desktop. It finally resolved when I shifted the BlueTooth transmitter for my wireless Mouse+Keyboard from onboard USB2.0 port to the USB3.0 PCI expansion card. I had tried modifying grub, it worked till i updated Kernel. Seems like some USB related bug.

0

For me, it helped to add xhci_hcd.quirks=270336 into GRUB_CMDLINE_LINUX_DEFAULT variable defined in /etc/default/grub and run sudo update-grub.

Here are some links to bug reports:

And here is some information about that xhci quirk:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=e95829f474f0db3a4d940cae1423783edd966027

The Intel desktop boards DH77EB and DH77DF have a hardware issue that can be worked around by BIOS. If the USB ports are switched to xHCI on shutdown, the xHCI host will send a spurious interrupt, which will wake the system. Some BIOS will work around this, but not all.

The bug can be avoided if the USB ports are switched back to EHCI on shutdown. The Intel Windows driver switches the ports back to EHCI, so change the Linux xHCI driver to do the same.

Unfortunately, we can't tell the two effected boards apart from other working motherboards, because the vendors will change the DMI strings for the DH77EB and DH77DF boards to their own custom names. One example is Compulab's mini-desktop, the Intense-PC. Instead, key off the Panther Point xHCI host PCI vendor and device ID, and switch the ports over for all PPT xHCI hosts.

The only impact this will have on non-effected boards is to add a couple hundred milliseconds delay on boot when the BIOS has to switch the ports over from EHCI to xHCI.

The only thing I have to add that I have ASRock Fatal1ty z97 professional motherboard with i5-4690k installed but the quirk still helped me, so I guess it worth a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.