I've installed ubuntu-desktop on Ubuntu 16.04 Gnome and I picked lightdm and now once I restart, I get this error message when I press CTRL + ALT + F2:

A start job is running for Hold until boot process finishes up (Xmin Xs/no limit)

This goes on for 20 minutes+. What do I do to fix this problem or even troubleshoot?

  • FYI after upgrade left mine running overnight - so 10+ hours same issue. May 30, 2016 at 2:51
  • My ubuntu 17.04 has the same error just now, ctrl+shit+N change tty, login, reboot, no more error. Not sure it will happen again in future or not though.
    – 林果皞
    Dec 7, 2017 at 6:59
  • A possible fox for a similar-sounding issue on Ubuntu 17 can be found at askubuntu.com/a/1007917/156671.
    – Brad Werth
    Feb 20, 2018 at 5:55

7 Answers 7


You can fix this in following way, it worked for me. FYI : I had upgraded from 14.04 to 16.04.

Go in your safe mode by hitting SHIFT key or ESC. select networking , then drop to root prompt. Then run following commands.

sudo apt-get remove plymouth
sudo apt-get remove xserver-xorg-video-intel

Now, reboot,

When you reboot, still you may get black or purple screen,

Press Ctrl+Alt+F1 and login with your username and password.

Then run following commands.

GDM ie Gnome display manager was also causing problems for me, so following step was essential for me

I switched to lightdm from gdm3 as display manager.

sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm

When you are prompted, select default display manager as lightdm

Now I was back with desktop , without dash or unity but only icons and wallpaper. now run this.

sudo apt-get install ubuntu-desktop

Now, reboot after this.

The desktop is back!

now, you can install intel graphic drivers again,

sudo apt-get install xserver-xorg-video-intel

Reboot now. Its done!

  • 9
    The great penguin god bless you, awesome human. You saved me. May 7, 2016 at 3:11
  • Upgraded from 15.10 to 16.04 because of libcogl and/or Nvidia issues, same problem. Removing plymouth and lightdm did it for me. May 30, 2016 at 2:52
  • I didn't need to uninstall plymouth to fix the issue (and I was getting a scary prompt concerning cryptsetup doing so in the root shell). Switching to lightdm helped, yet I was getting stuck in a login loop. To fix it I had to chown .Xauthority
    – k0pernikus
    Jun 1, 2016 at 16:48
  • 2
    I got errors saying the file system was mounted read-only (even in recovery???) so I had to do this: mount -o rw,remount /
    – trpt4him
    Jul 24, 2016 at 14:16
  • At the end, my session was opening then closed immediately: i had to do this: chown myusername /home/myusername/.Xauthority
    – laugeo
    Aug 13, 2016 at 19:20

Had the same problem earlier today.

Found out here (https://bbs.archlinux.org/viewtopic.php?id=195223) that could be a plymouth related problem, and after removing it (I'm really not into looping logins animations anyway...), I got into trouble with nvidia drivers.

I just removed all nvidia related software and, voilà, I'm here typing this answer.

sudo apt-get remove plymouth
sudo apt-get purge nvidia
sudo reboot
  • Had the same problem and this worked for me. Thanks Apr 23, 2016 at 9:15
  • 1
    Actually, I fixed my issue. I just did sudo apt-get purge nvidia-common and that fixed the problem.
    – Raza
    Apr 23, 2016 at 20:59

For those who messed up with Linux booting after the update (Which happened to many users including me) Here's the complete solution (Which I used, and I was able to get back everything).

  1. Don't panic!
  2. If your computer is hanged at the login screen, press Ctrl+Alt+f2
  3. It will ask for your login username and password.
  4. Connect ethernet cable (LAN cable) from your wifi router or modem to your computer
  5. Type dhclient eth0 and press enter
  6. For testing networking, try ping www.google.com if there's any failure then please check your LAN connection, router or modem (Connecting to WiFi is a tedious process so try LAN connection first)
  7. Type reboot and press enter.
  8. Now keep pressing Esc or Shift key.
  9. Enter into latest kernel recovery mode.
  10. Use keyboard arrow keys to navigate.
  11. Press Enter on Networking
  12. Now it will display the previous screen.
  13. Click on root (You need root access to modify system).
  14. Run

    sudo apt-get install -f --reinstall lightdm

    (It will download 200mb of data)

  15. Run

    sudo apt-get install unity
  16. Run

    sudo apt-get install ubuntu-session
  17. Run

    sudo dpkg-reconfigure lightdm
  18. It will ask you to select one out of two options: gdm & lightdm. Select lightdm
  19. Run

    sudo apt-get install gnome

    ( It will download 700mb of data)

  20. Run reboot and you should be able to get your work back (Although your desktop will look ugly because of conflicting themes. Don't worry, steps 23 & 24 will fix this issue).
  21. Open terminal (Ctrl+Alt+T) and run

    sudo apt-get autoremove

    (to purge all unnecessary dependencies which can cause problems while installing new packages)

  22. Run

    sudo apt install unity-tweak-tool
  23. Run

    sudo apt-get autoremove --purge light-themes
  24. Run

    sudo apt-get install light-themes
  25. Finally download ubuntu-tweak from ubuntuupdates.com (version that works with Xenial Xerus and isn't available anywhere else!)
  26. Reboot your system and done!
  • Big round of applause! Saved my day! Sep 16, 2016 at 9:58
  • This did NOT fix the theme conflict problem. The icons are conflicted, when I drag e.g. terminal, it doesn't drag in real time (imagine dragging folders in windows XP), etc. Can anyone help?
    – busuu
    Mar 18, 2018 at 15:49
  • if it hangs during boot (e.g. Failed to start Login Service), control+alt+f2 won't show an usable tty though... Dec 5, 2018 at 4:01
  • @FlorianCastellane it should work but if it is not working you may check function keys in your boot menu if they need 'fn+f2' or just 'f2' Jan 22, 2019 at 1:57
  • that's not for entering the boot menu, that's for accessing tty2 Jan 22, 2019 at 2:27

I just had the same issue on a fresh Ubuntu 19.04 on a ThinkPad X201. The system would hang forever with a black screen and not react to any keyboard input. At next reboot (into recovery mode) when examining /var/log/boot.log I would see the error told in the question:

A start job is running for Hold until boot process finishes up (Xmin Xs/no limit)

Funny enough, I was able to start in recovery mode until I see the recovery mode menu and, from there, when choosing "resume" I would get to the normal graphical environment. The difference to a normal mode was only that the boot process was done in text mode. This indicates that there is a conflict between the display manager and plymouth, the software responsible for showing the graphical screen with the Ubuntu logo etc. while the computer boots up.

And indeed, the only step required to fix this was removing plymouth, by executing in recovery mode:

sudo apt remove plymouth

And rebooting.

  • This worked for me. Had the exact same solution.
    – Axel
    May 16, 2019 at 9:34
  • Thanks, that solved my problem too .. However the animated Ubuntu logo disappeared. But who cares! Jul 17, 2019 at 9:13

Ran into the same problem after installing the Nvidia driver (361). I removed it and its all working okay now. I have a GeForce 920 (Optimus). Nouveau works fine with it, so I shall stick with it for a few more months and try installing the Nvidia driver again (hoping the bug will have beebln fixed by then).


You can skip the wait and go to your log-in screen directly by using 'Ctrl+c' and then work on the solution. Sometimes this will go on forever if not.


Another solution is to download the mini.iso version of the installer; it bypasses the problem. Be sure to have a good internet access when you install it, it will download a lot of files.

During the setup, you will be asked which kind of Ubuntu to install.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .