I've installed ubuntu-desktop on Ubuntu 16.04 Gnome and I picked lightdm and now once I restart, I get this error message when I press CTRL + ALT + F2:

A start job is running for Hold until boot process finishes up (Xmin Xs/no limit)

This goes on for 20 minutes+. What do I do to fix this problem or even troubleshoot?

  • FYI after upgrade left mine running overnight - so 10+ hours same issue. – Zayne S Halsall May 30 '16 at 2:51
  • My ubuntu 17.04 has the same error just now, ctrl+shit+N change tty, login, reboot, no more error. Not sure it will happen again in future or not though. – 林果皞 Dec 7 '17 at 6:59
  • A possible fox for a similar-sounding issue on Ubuntu 17 can be found at askubuntu.com/a/1007917/156671. – Brad Werth Feb 20 at 5:55
up vote 45 down vote accepted

You can fix this in following way, it worked for me. FYI : I had upgraded from 14.04 to 16.04.

Go in your safe mode by hitting SHIFT key or ESC. select networking , then drop to root prompt. Then run following commands.

sudo apt-get remove plymouth
sudo apt-get remove xserver-xorg-video-intel

Now, reboot,

When you reboot, still you may get black or purple screen,

Press Ctrl+Alt+F1 and login with your username and password.

Then run following commands.

GDM ie Gnome display manager was also causing problems for me, so following step was essential for me

I switched to lightdm from gdm3 as display manager.

sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm

When you are prompted, select default display manager as lightdm

Now I was back with desktop , without dash or unity but only icons and wallpaper. now run this.

sudo apt-get install ubuntu-desktop

Now, reboot after this.

The desktop is back!

now, you can install intel graphic drivers again,

sudo apt-get install xserver-xorg-video-intel

Reboot now. Its done!

  • 6
    The great penguin god bless you, awesome human. You saved me. – David Castillo May 7 '16 at 3:11
  • Upgraded from 15.10 to 16.04 because of libcogl and/or Nvidia issues, same problem. Removing plymouth and lightdm did it for me. – Zayne S Halsall May 30 '16 at 2:52
  • I didn't need to uninstall plymouth to fix the issue (and I was getting a scary prompt concerning cryptsetup doing so in the root shell). Switching to lightdm helped, yet I was getting stuck in a login loop. To fix it I had to chown .Xauthority – k0pernikus Jun 1 '16 at 16:48
  • 2
    I got errors saying the file system was mounted read-only (even in recovery???) so I had to do this: mount -o rw,remount / – trpt4him Jul 24 '16 at 14:16
  • At the end, my session was opening then closed immediately: i had to do this: chown myusername /home/myusername/.Xauthority – laugeo Aug 13 '16 at 19:20

Had the same problem earlier today.

Found out here (https://bbs.archlinux.org/viewtopic.php?id=195223) that could be a plymouth related problem, and after removing it (I'm really not into looping logins animations anyway...), I got into trouble with nvidia drivers.

I just removed all nvidia related software and, voilà, I'm here typing this answer.

sudo apt-get remove plymouth
sudo apt-get purge nvidia
sudo reboot
  • Had the same problem and this worked for me. Thanks – Nicklas2751 Apr 23 '16 at 9:15
  • 1
    Actually, I fixed my issue. I just did sudo apt-get purge nvidia-common and that fixed the problem. – Raza Apr 23 '16 at 20:59

For those who messed up with Linux booting after the update (Which happened to many users including me) Here's the complete solution (Which I used, and I was able to get back everything).

  1. Don't panic!
  2. If your computer is hanged at the login screen, press Ctrl+Alt+f2
  3. It will ask for your login username and password.
  4. Connect ethernet cable (LAN cable) from your wifi router or modem to your computer
  5. Type dhclient eth0 and press enter
  6. For testing networking, try ping www.google.com if there's any failure then please check your LAN connection, router or modem (Connecting to WiFi is a tedious process so try LAN connection first)
  7. Type reboot and press enter.
  8. Now keep pressing Esc or Shift key.
  9. Enter into latest kernel recovery mode.
  10. Use keyboard arrow keys to navigate.
  11. Press Enter on Networking
  12. Now it will display the previous screen.
  13. Click on root (You need root access to modify system).
  14. Run

    sudo apt-get install -f --reinstall lightdm
    

    (It will download 200mb of data)

  15. Run

    sudo apt-get install unity
    
  16. Run

    sudo apt-get install ubuntu-session
    
  17. Run

    sudo dpkg-reconfigure lightdm
    
  18. It will ask you to select one out of two options: gdm & lightdm. Select lightdm
  19. Run

    sudo apt-get install gnome
    

    ( It will download 700mb of data)

  20. Run reboot and you should be able to get your work back (Although your desktop will look ugly because of conflicting themes. Don't worry, steps 23 & 24 will fix this issue).
  21. Open terminal (Ctrl+Alt+T) and run

    sudo apt-get autoremove
    

    (to purge all unnecessary dependencies which can cause problems while installing new packages)

  22. Run

    sudo apt install unity-tweak-tool
    
  23. Run

    sudo apt-get autoremove --purge light-themes
    
  24. Run

    sudo apt-get install light-themes
    
  25. Finally download ubuntu-tweak from ubuntuupdates.com (version that works with Xenial Xerus and isn't available anywhere else!)
  26. Reboot your system and done!
  • Big round of applause! Saved my day! – Andrew Luca Sep 16 '16 at 9:58
  • This did NOT fix the theme conflict problem. The icons are conflicted, when I drag e.g. terminal, it doesn't drag in real time (imagine dragging folders in windows XP), etc. Can anyone help? – Milan Mar 18 at 15:49

Ran into the same problem after installing the Nvidia driver (361). I removed it and its all working okay now. I have a GeForce 920 (Optimus). Nouveau works fine with it, so I shall stick with it for a few more months and try installing the Nvidia driver again (hoping the bug will have beebln fixed by then).

You can skip the wait and go to your log-in screen directly by using 'Ctrl+c' and then work on the solution. Sometimes this will go on forever if not.

Another solution is to download the mini.iso version of the installer; it bypasses the problem. Be sure to have a good internet access when you install it, it will download a lot of files.

During the setup, you will be asked which kind of Ubuntu to install.

protected by Community Aug 21 '16 at 0:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.