2

Installed Ubuntu 16.04 here are my specs:

OS: Ubuntu 16.04 LTS x86_64
Kernel: 4.4.0-21-generic
Uptime: up 17 hours, 39 minutes
Packages: 3268
Shell: /usr/bin/fish 
Resolution: 1366x768
Desktop Environment: XFCE
Window Manager: Xfwm4
Theme: Numix Solarized [GTK2], Arc-Dark-Solid [GTK3] 
Icons: Numix-Circle [GTK2], Numix-Circle-Light [GTK3] 
CPU: E1-2100 APU (2) @ 1.0GHz
GPU: AMD KabiniRadeon HD 8210  
Memory: 1326MB / 3418MB

When I restarted after doing the update, Ubuntu Software Center was still there and crashed when opened. So I uninstalled it and restarted it again but gnome software center still wasn't there. So I tried to install it using sudo apt install gnome-software but what I got was this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-software : Depends: appstream but it is not installable
                  Depends: libgnome-desktop-3-12 (>= 3.17.92) but it is not installable
                  Depends: libgtk-3-0 (>= 3.18) but 3.16.7-0ubuntu3 is to be installed
E: Unable to correct problems, you have held broken packages.

Please advise!

  • How did you install Ubuntu 16.04 and what is the output of apt-cache policy libgtk-3-0? – Florian Diesch Apr 22 '16 at 19:10
  • libgtk-3-0: Installed: 3.16.7-0ubuntu3 Candidate: 3.16.7-0ubuntu3 Version table: *** 3.16.7-0ubuntu3 100 100 /var/lib/dpkg/status – Michael Smith Apr 22 '16 at 19:24
  • um thats not it – Michael Smith Apr 22 '16 at 19:36
  • If that's the full output you don't have any software sources configured. What the output of grep -v '^ *#' /etc/apt/sources.list | head -5 – Florian Diesch Apr 22 '16 at 19:37
  • @Takkat: No, it's a problem with the software sources. – Florian Diesch Apr 22 '16 at 19:40
2

You don't have any software sources configured, which means something went wrong with your installation. As there may be more problems I'd install the system again. Make sure you use an official up-to-date Xubuntu image.

If you want to try to repair your system you can use for example https://repogen.simplylinux.ch/ to create a new sources.list

After saving the new /etc/apt/sources.list run

sudo apt-get update
sudo apt-get dist-upgrade

apt-get should offer you to upgrade some packages. Do that, and then run

sudo apt-get install xubuntu-desktop

to get all the software installed for Xubuntu by default.

  • which ones should i pick? – Michael Smith Apr 22 '16 at 20:17
  • Everything in section "Ubuntu Branches", "Security and "Updates" in section "Ubuntu Updates" . You can omit all "Sources Repository" if you are not interested in downloading source codes. – Florian Diesch Apr 22 '16 at 20:22
0

I've got same failure with my upgrade to 16.04 LTS. I've tried several way like :

sudo apt-get install -f

but some packages remain not installed.

I've repaired my upgrade by reinstalling all packages. You must exclude the libgtk-3-* packages from the install process, because they have dependencie failures.

sudo apt-get --reinstall install $(dpkg-query -f '${binary:Package}\n' -W | grep -v "libgtk-3")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.