After 15.10 to 16.04 upgrade some fonts/characters (Chinese, Japanese and Korean) in Chrome and Chromium became so thin that they are almost impossible to read. Some random search result from Google looks like this: Google search page

In terminal it says Fontconfig error: Cannot load default config file few times. What the problem can be?

  • There is no need to only install the regular weight there. I just removed the package via apt-get and manually installed all weights from Google, and it seems to work well. – xji Apr 28 '16 at 4:57
  • @XiangJi Could you share a bit more detail? – pvc Apr 28 '16 at 8:00
  • I originally posted an answer which seems to be deleted for being a duplicate of the answer I provided at my question asked at askubuntu.com/questions/763632/… Now I modified it and posted again. – xji Apr 28 '16 at 14:14
up vote 2 down vote accepted

For some reason Chrome keeps defaulting to Noto Sans CJK Thin. Simplest solution is to replace the NotoSans font bundled with Ubuntu with just the regular weight.

Idea sparked by noto-sans-cjk-thin-font-issue

In short:

Benefit: no thin browser font rendering.

Drawback: no font weights other than regular!

  • This workaround seems to be working. One thing… don't do that from X11 since it may freeze when overwriting the file (as mine did). I had to switch to text tty to replace this file. – pvc Apr 26 '16 at 8:47
  • Yeah it's not a great solution - hopefully we can switch back to the full Noto Sans once the font weight issues are addressed/fixed. – Subrosa Apr 27 '16 at 3:01
  • There is no need to only install the regular weight there. You can just remove this package and manually install all weights, and it should work fine. See my answer below. – xji Apr 28 '16 at 4:56
  • Looks like they have finally fixed it with todays update. So as now for now, updating your software should fix the issue. This update also reverts back the effects of the workaround mentioned in this answer. – pvc May 26 '16 at 9:43

I use another work-around: in chromium settings -> customize fonts, change "standard font" to use "Noto Sans CJK", like me use "Noto Sans CJK SC";

I reported the bug. According to the discussion it could be something related to fontconfig or the internal font fallback mechanism of Chrome.

Anyways, I seemed to temporarily solve it by removed the package via apt-get and downloading NotoSansCJK directly from Google, which contains fonts of different weights in separate files. After installing the fonts manually this issue seems to be fixed, and Chrome is able to render CJK correctly even though I didn't change my default fonts in Chrome.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.