2

Just upgraded today, already regretting it. I have terrible VSync/tearing problems. Before it worked flawlessly.

I already tried all compositor settings, some of them seemed to temporarily remove tearing, but after about a minute I could notice it again.

In addition to that I can't enter my full-disk-encryption password when it starts the GUI version, only when I reset the PC and it starts the fallback CLI version.

GPU: GTX 780
CPU: i7 4790k
Screens: 3x 1080p (DVI-I + DVI-D + DP -> DVI)

Driver: Latest Proprietary Nvidia Driver (just updated today after upgrading)

3

Solution For The Tearing Problem

As /u/ropid suggested, I tried adding this

__GL_YIELD="USLEEP"
KWIN_TRIPLE_BUFFER=0
KWIN_USE_BUFFER_AGE=0

to /etc/environment.

This fixed the tearing issue for me.

Solution For The Encryption Problem

I found this link, which suggested to do the following:

sudo nano /etc/default/grub

Then replace

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

This disabled the GUI password prompt. The CLI version successfully detects my keyboard.

  • The solution for the tearing problem listed above worked but had some artifacting with my Kubuntu 16.04 installation on an Intel i7-2600K Sandybridge processor with Intel integrated HD 3000 graphics. I posted a solution that worked better for me at Screen Tearing on Kubuntu 16.04 with Intel Drivers? – Curtis Gedak May 21 '16 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.