I have a Lenovo ThinkPad 11e (with the Intel chipset not the AMD), that used to experience freezes randomly under 14.04 which have persisted after a clean install of 16.04.

Description of the freezes that occur:

  • Screen freezes in place with no distortion
  • Hardware buttons become unresponsive (lights in the mute sound/mic keys no longer toggle when pressed)
  • A hard restart is the only way to fix the freeze
  • There is absolutely no warning before a freeze occurs, the system acts normally right up until it locks up

The issue seems to appear more frequently when I run anything related to Chrome/Chromium on my system (including stuff that uses the Electron framework, e.g. the Atom editor). But it will still occur even if nothing related to those is running. It also doesn't seem to be related to stress on the system because I can run Windows 10 in VMWare Workstation 12 without any issue.

I'm not even sure where I should begin looking in for clues as to what's causing the issue, so I was hoping someone here might have an idea. When the issue occurs the entire computer becomes unresponsive and I have to hard shut down. I'm not sure what logs would have any information related to a hard system freeze.

I have tried using linux-crashdump as suggested by Chris J Arges, but even after replicating my problem twice I have found no crash entries in /var/crash other than those from forcing a kernel crash to make sure it was working

Possibly relevant information:

  • The integrated Intel graphics show up as Intel Bay Trail (which I know has had some problems with Linux in the past)
  • I have upgraded the system to 8 GB of RAM (the issue occurred before this change as well)
  • My system has an SSD formatted to ext4 (the issue occurred using btrfs as well)
  • I have run multiple hardware diagnostic tests (both built-in BIOS tests and from bootable utilities), that have found no issues with my hardware
  • You may try kernel the command line ... intel_idle.max_cstate=1. If you see a "missing firmware" message when running update-initramfs try to get the missing firmware file.
    – user534699
    Apr 24 '16 at 20:30
  • Where exactly would I put "intel_idle.max_cstate=1" before running update-initramfs?
    – Ian
    Apr 25 '16 at 18:51
  • I have this same issue. My laptop is an Acer E5-511, also Intel based, but also running on an SSD hard drive. May 2 '16 at 7:09
  • How much swap memory do you have ? I've had issue where my system would run out of swap and freeze up just as you've described, had to increase swap amount. May 3 '16 at 5:17
  • Acer E1-510P, intel based, running original hard drive (not SSD). Windows 10 perfectly stable. But fresh install (format partitions) of Ubuntu 16.04 freezes in same way (entirely unresponsive) playing Netflix in Chrome - typically in 1 hour or less. Seems to be a CPU loop, as I notice that the fan goes to 100% on crash. I suggest marking this Ubuntu bug as one you have: bugs.launchpad.net/ubuntu/+source/linux/+bug/1575467 - people reported using older 3.16 kernel seems to work around it. So a kernel bug. May 7 '16 at 9:55

Try installing newer kernels. In some cases, it fixes the problem of freezing that caused by bad high precision timer code. This is binary for Linux 4.5.2:


Download appropriate 3 .deb binary packages, install them, and reboot to the new kernel. I hope this will fix your problm. By the way, Ubuntu 16.04 is alraedy out with a new kernel, so do a clean install (not an upgrade) and see if it fixes your problem.

  • 1
    I believe the updated kernel fixed my issue. I was able to have Chrome open for several hours without experiencing any crashes. Being as this seems to have fixed the issue and the bounty is about to expire I'm just going to accept this as the answer.
    – Ian
    May 3 '16 at 17:18
  • 1
    @IanLantzy I'm happy to see that your problem is fixed. In fact, debugging such problems is very tricky, and only a handful of people can debug and fix them. This perticular problem with HPET (if it was the case) was there for a long time, and it took a while to be understood and fixed by kernel gurus. Phoronix (phoronix.com) is a good place to be informed about the recent advances in Linux and its possible problems.
    – Ho1
    May 4 '16 at 12:25
  • I have a Ubuntu 16.04 VM booted from a live CD that's frozen (on the same HW). You could debug that. May 24 '16 at 15:35
  • 1
    I have installed the latest kernel, and it does not seem to have fixed the problem after all - it just froze twice in a row after a week of not freezing. Jun 4 '16 at 18:45
  • 1
    Yes I've noticed the problem seems to be persisting, but has gotten better with high kernel versions. It's likely some kind of hardware/firmware issue that will eventually be fixed.
    – Ian
    Jun 12 '16 at 7:59

See https://bugzilla.kernel.org/show_bug.cgi?id=109051

The following eliminated the problem for me.

Edit /etc/default/grub. Change the line



GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1 quiet splash"

then do

sudo update-grub

and reboot.

  • 2
    Please be aware that this change will increase the power consumption (especially a issue when running on battery). Sep 3 '16 at 13:39

There isn't enough information to diagnose this so you should file a bug. I'm assuming when you mention 'freeze' the computer needs to be completely power cycled to use it again. With that it is most likely a kernel issue. The following link explains how to file a bug against the Ubuntu kernel: https://wiki.ubuntu.com/Kernel/Bugs

Another approach is to use linux-crashdump to try and capture the failure when it happens. Instructions are here: https://wiki.ubuntu.com/Kernel/CrashdumpRecipe

Finally you could try installing the latest mainline kernel to see if this fixes the issue. This would be useful information to report in the bug as well: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/

  • Part of my question is asking where I should be looking for information regarding what happens when it crashes. I'd have to imagine one of the logs somewhere must have something.
    – Ian
    Apr 22 '16 at 20:37
  • Yes, getting a crashdump will save the kernel log upon crash so you can review it. When the system crashdumps it will store the log into /var/crash/<timestamp>/<timestamp>.dmesg .
    – Chris
    Apr 26 '16 at 15:04
  • I installed crashdump and it works when I test it, however I've forced my problem to occur twice now (by playing Bloons TD 5) and no crashes have been logged either time
    – Ian
    Apr 27 '16 at 16:59

In your possible relevant issues, you mentioned:

The integrated Intel graphics show up as Intel Bay Trail (which I know has had some problems with Linux in the past)

Here's my personal experience. I have had a similar issue. It was an NVidia GT820M Card. I always had issue using the proprietary drivers from Nvidia

enter image description here

What fixed it for me was using Nouveau Xorg drivers instead. I would switch between them to confirm that was the culprit. The same symptoms as yours would happen. PC will stop responding in the middle of anything anytime without any warning whatsoever. And Chrome browser or Sublime would trigger the freeze easily too.

If you happen to be using a proprietary VGA driver for your PC, switch to an open source version, preferably the nouveau.

And this my experience happened on an Ubuntu i7 15.04. The issue is long gone, and I am free now, but from all you describe I'm happy to put 20 points bounty on the VGA drivers as the culprit

  • Nope, the only additional driver I have in use is just the additional microcode for the processor itself. There's no driver installed for the Bay Trail integrated GPU. Very good answer, though.
    – Ian
    May 3 '16 at 17:16
  • @IanLantzy plus you did mention you know the Bay Trail has past record of giving problems. I guess that's a bigger sign of it being the culprit. Edit: Just realized the kernel build fixed your issue. Good to know. Will keep that in mind myself. Thanks
    – KhoPhi
    May 3 '16 at 21:22

I was experiencing the same problem on an ASUS N56JN (also Intel chipset). This worked for me:


It basically explains how update the kernel to the latest version, goes step by step on how to download, compile and install the latest version of the Linux kernel (4.5).

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Tim
    May 1 '16 at 23:46
  • Were you experiencing the same issue on the same kind of laptop?
    – Ian
    May 2 '16 at 18:21
  • No, on an ASUS N56JN, also intel chipset not AMD. I refer to the problem that it was randomly freezing after upgrading to 16.04.
    – CMorales
    May 3 '16 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.