In the new Gnome Software in 16.04, the keyboard is weird - whenever I type in the search bar, keys get pressed twice:

I've tried disabling "Key presses repeat when key is held down" in Control Center -> Keyboard.

Search bars and text fields in other GTK 3 apps work perfectly. This is on a fresh install of Ubuntu 16.04.

up vote 4 down vote accepted

I also had this problem, did some searching and found this. It fixes the issue for me no longer getting double letters

Install ibus-gtk In the terminal do

sudo apt-get install ibus-gtk ibus-gtk3

Reboot. (Does not work until rebooted)

Should work now!

  • Sorry, but didn't work – UniversallyUniqueID Apr 23 '16 at 7:06
  • 1
    Did you reboot? also try sudo apt-get install ibus-gtk3 – Jonny Apr 23 '16 at 14:54
  • Thank you! ibus-gtk3 solved it. Please edit your answer to say ibus-gtk3 instead of just ibus-gtk. – UniversallyUniqueID Apr 24 '16 at 6:29
  • I have this issue only with a wired USB keyboard. Disabling keystrokes changes nothing on the wired and the command above + reboot didn't worked so far. Neither changing the input language – FabioCosta May 3 '17 at 20:45

I had the same problem after upgrading to 16.04.

I had previously disabled IBus when I was running <=15.10 due to an issue with the Jetbrains Pycharm IDE.

Renabling IBus fixed the issue with Gnome Software for me.

Try opening your system Settings ­> Language Support and ensuring the Keyboard input method at the bottom of the page is set to ibus. If it was set to none, reboot after you change the setting.

I had the same problem with a fresh installation of Ubuntu 16.10. with Gnome. I tried the sudo apt-get install ibus gtk fix before that and this did not work for me.

I had the language set on my first language (Dutch).

I changed it in the settings to English (United States) and this fixed it for me.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.