Dell Inspiron n5110, I upgraded from Trusty to Xenial yesterday.. The one issue I can't seem to get past or over is that when I use the Fn keys to change the brightness, it results in random flickering during which, the brightness bar moves in either direction or at times it stays put. If I change the brightness via the slider in System settings, it works fine (but should it allow reduction to a zero i.e. blackout?).

I have already tried creating the intel file in xorg.conf.d, here's the output for:

~$ ls /sys/class/backlight
acpi_video0  intel_backlight

The flickering and the output has led me to think about the possibility that the Fn keys seem to be commanding two drivers at once?

1 Answer 1


I was able to find a fix for it. Not fully satisfied, but technically the issue is fixed. Here, I blogged about it.

Update: The original blog is down. Its content can still be found on archive.org though. Below is a quotation of the linked content's key parts:

After googling further on this, I landed on this page and I saw the list of kernel parameters that had to do with the backlight. I rebooted a couple of times, each time trying a different parameter, and finally, acpi_backlight=native is what did the trick. I noticed that it doesn’t allow me to change brightness on login screen, but after login, there was no flickering, and when I ran ls /sys/class/backlight/, I saw that it no longer returned acpi_video0. The only issue I have right now is that there is no fixed minimum. Sometimes, it decreases to a reasonable minimum, while at other times, it results in a blackout, and I have to manually adjust it using the slider in system settings or using xbrightness..

To replicate this process, all you need to do:

  • Fire up a terminal
  • sudo nano /etc/default/grub
  • At the very end of the string GRUB_CMDLINE_LINUX_DEFAULT, (which in my case was quiet splash) add acpi_backlight=native.
    The final string, in my case, looks like quiet splash acpi_backlight=native
  • Close and save the file, and run sudo update-grub and then reboot.

In the event that this doesn’t work, it’d be worth your time to try out the rest of the kernel parameters. You don’t have to modify the grub file every time. Instead you can choose to modify kernel parameters before boot. This you can do by pressing “c” on the grub screen and typing the desired parameter, in the correct place, right after “splash.”

  • I just happened to have the same exact same laptop as you did and this worked!
    – intcreator
    May 21, 2017 at 5:05
  • 1
    Please include the actual answer in your answer and not just a link. As it stands now the link is gone and this answer is useless.
    – Calimo
    Mar 10, 2018 at 18:08
  • For my future fellows who come here looking for the fix, see the above blog URL, open it and get frustrated that it is now dead, I bring to you the blog; here on Wayback Machine, the OP did kind of "fix" it, I did revert my issue (on Arch Linux) by removing the xorg config I generated
    – Sid Sun
    May 31, 2019 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.