This seems to have previously been a problem starting in 15.10, and after upgrading to Ubuntu GNOME 16.04 the problem is still not solved. Click to focus specifically seems to be bugged on GNOME applications. I can get the windows to be active by clicking on the title bar, but I cannot simply click anywhere in the window.

I can "work around" this issue by changing the raise behavior to "sloppy" or "mouse" but those solutions do not work for me because I constantly move the mouse to the side of a window or work with windows on top of one another and sloppy and mouse constantly do what I do not want them to do, which is raise a window and make it active by having my mouse over it.

More than not being raised, they also seem to not really be "active", as trying to type in those windows results in the input being in the raised window. I can drag and drop a file/icon into a nautilus window and it works, but if I select files with my mouse and try to ctrl+v them, they will not be copied.

Any help?

  • You're not alone. I'm having the same issue on 16.04. I'm running with Gnome 3.20 if that makes any difference. – PKKid May 2 '16 at 0:52

I was having problems with "click focus" as well, mainly with Chrome (not using system title bar) and Guake and what did the trick for me was setting from dconf-editor, org.gnome.desktop.wm.preferences values as follows:

  • auto-rise: on
  • focus-mode: click
  • focus-new-windows: strict (*)
  • mouse-button-modifier: default

(*) It seems to affect the focus behaviour of windows with no title bar (such as Google Chrome and Guake).

Hope it helps.

Edit: Ubuntu 16.04 w/ Gnome-shell 3.18.4


I was just tinkering with this a bit more and solved my own problem. I had messed with some of the settings in Ubuntu Tweak Tool and it seems unrelated but disabling the 'mouse-modifier-button' was causing the windows not to raise unless clicking the titlebar. Setting this value back to default '' fixed the raise issue.

Open dconf-editor and navigate to org.gnome.desktop.wm.preferences and make sure mouse-modifier-button and raise-on-click are both set to default. If that doesn't do it, maybe another setting in there is not default and causing your issue.


Use Alt+click. It worked for me.


Use alt+` switch between same application


had the same exact issue when "Window Action Key" was set to "Disabled"

setting that to "Alt" or "Super" made it focus normally only click

  • Do you mean in gnome-tweaks? Also, why do you think that could solve the issue with the mouse? – Dominic108 Dec 30 '19 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.