7

EDIT 1: I reinstalled 16.04 having booted through the CD but with the HDD installed, now I can read the "readme.txt" and I can click on the "access-your-private-data.desktop" and it seems to run for a few minutes without a window opening and then it stops. When I try running sudo ecryptfs-recover-private I get

INFO: Searching for encrypted private directories (this might take a while)...
find: ‘/run/user/1000/gvfs’: Permission denied

I have a Lenovo E540 (i7) with a 16GB SSD and 1TB HDD. I had the system and swap on the SSD and my data (/home) on the HDD. I tried updating from 14.04 to 16.04. I got asked to confirm the driver EULA but I couldn't select the "OK". I quit the installation. After trying to boot up all I got was an empty screen. I created a 16.04 live cd on a different machine and booted up with that. I removed my hdd prior to this because I didn't want to risk loosing any data. After the installation I shut the notebook down and installed the HDD. I booted up and my HDD appears as a volume and when opened there's two files "access-your-private-data.desktop" "readme.txt" neither of which I can open. I had all my files on the HDD, please help me.

5
  • That's because you're trying to access the disk via a nautilus user mount which (by default) is only readable by the user. Have you tried mounting it conventionally (i.e. creating a mount point such as /mnt/hdd and then identifying the partition / blockid and mounting it manually)? – steeldriver Apr 22 '16 at 16:44
  • @steeldriver cha@cha:~$ sudo mount /dev/sda5 /mnt/hdd [sudo] password for cha: mount: mount point /mnt/hdd does not exist cha@cha:~$ sudo mkdir /mnt/hdd cha@cha:~$ sudo mount /dev/sda5 /mnt/hdd cha@cha:~$ ecryptfs-mount-private ERROR: Encrypted private directory is not setup properly cha@cha:~$ sudo ecryptfs-recover-private INFO: Searching for encrypted private directories (this might take a while)... find: ‘/run/user/1000/gvfs’: Permission denied – chaosdoom Apr 23 '16 at 12:43
  • @steeldriver also tried cha@cha:~$ sudo blkid /dev/sda1: PARTUUID="0003bf27-01" /dev/sda5: UUID="219d17f0-e4be-4df6-ba4a-e6037a0d979b" TYPE="ext4" PARTUUID="0003bf27-05" /dev/sdb1: UUID="fb4b09cf-2c5c-4b72-b8e2-69813f8d9ae6" TYPE="ext4" PARTUUID="00021ea9-01" /dev/sdb5: UUID="b0db487b-fa9f-4fe1-a94f-e8afa77e6b8c" TYPE="swap" PARTUUID="00021ea9-05" – chaosdoom Apr 23 '16 at 12:50
  • Hi @SamuelJozefZeman ! I have exactly the same problem, any updates on a solution you found? Thanks! – Matifou Jul 10 '16 at 15:54
  • unix.stackexchange.com/questions/77453/…. The answer at the bottom of the page. – WSPalmBeach Aug 6 '16 at 4:04
3

ecryptfs-recover-private doesn't have to search through every file, if you add where your old encrypted home at the end then it will only look there. For example ecryptfs-recover-private /location/to/search.

You can search yourself, looking for any encrypted files, for example with a GUI search utility, or
find [mountpoint] -type f -iname "*ecryptfs*"

To see exactly what ecryptfs-recover-private does, just look at it, it's a bash script. Running this would display it with less:
less $( which ecryptfs-recover-private )

And it's search is this:
find / -type d -name ".Private"

You're probably just seeing regular "permission denied" errors if you tried searching everything everywhere, some folders don't want to be searched. Your home's not supposed to be in /run/user/1000/gvfs anyway so don't worry about it.

1
  • It would be great if you mentioned how to tell ecryptfs-recover-private to look in a specific place – Enkouyami Nov 8 '16 at 3:11
0

I upgraded 15.10 to 16.04 and when trying to access my .private folder on an external drive from a backup with sudo ecryptfs-recover-private I was getting the same error. When I did the same thing from another 14.04 notebook everything was working as it should. So this might be a problem with 16.04?

0

I had this exact problem, too, and all I had to do was unmount the /gvfs directory using the command umount /run/user/1000/gvfs. I then ran the command ecryptfs-recovery-private and it worked. I know how freaked out I was when thinking I had lost my information.

0

I had similar errors after I renamed the previous (original) POSIX username to old_user (and ) and then created a new user with the original (previous username's) name.

To be able to mount the encrypted home directory from the old_user, I had to remake the symbolik links for .encryptfs and .Private in its folder (as they had poinded to /home/original_name/).

After that, the following command mounted the old home without any problem. /usr/bin/ecryptfs-recover-private /home/old_user/.Private

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.