This bug has now been fixed upstream. An update has been issued. If you still cannot install, ensure you have updated fully, and then restart your computer.

I am trying to install downloaded DEB packages. Each time, I see a warning like this:

And clicking install just loads and nothing changes.

This shows for all the packages I try and install. How can I install a package?

  • 2
    Why does that stop you installing it? It does contain non free components and is from a 3rd party, it is Google Chrome, just click install, all it is saying is that this was not distributed by Ubuntu.
    – Mark Kirby
    Apr 22, 2016 at 15:26
  • i would like to install it but when i click on Install it wont be installed :( Apr 22, 2016 at 15:57
  • 1
    same here, downloaded deb packages cannot be installed, the install button doesn't do anything
    – Stan
    Apr 22, 2016 at 15:58
  • 3
    Possible duplicate of 16.04 Cannot install anything from Ubuntu Software center Apr 24, 2016 at 14:50
  • 1
    The bug fix has been withdrawn because the link does not work and upgrading my system does not lead to clearance of the problem. The current status of the closure is invalid. Apr 26, 2016 at 21:03

8 Answers 8


This is bug #1573026. Make sure you click the "this affects me too".

This bug has now been fixed upstream. Hopefully an update will be issued promptly.

What are the workarounds?

You can use the GDebi package manager, available in the software centre or with sudo apt-get install gdebi via the command line.

Then, to install the package, open GDebi and click File -> Open and navigate to the downloaded DEB file.

It can take a little while to add the open the package - it took around 10 seconds for me.

Then check everything is OK, and click install.

It will finish, and the program will be installed.

Or we can use the command line. While apt-get cannot install from a DEB file, all apt-get does is download the file and then call dpkg. We can do those tasks ourselves really simply.

Open a terminal and navigate to our download location with cd.

And run the command:

sudo dpkg -i FileName.deb

replacing FileName with the name of the file.

Finally, run this:

sudo apt-get install -f

This "fixes" everything - it resolves all dependencies etc.

  • 3
    mark the bug report as "affects me", the more people do this the faster it will be fixed
    – Mark Kirby
    Apr 22, 2016 at 16:04
  • @MarkKirby Better to mark the bug report as "affects me" rather than pollute the bug report with extra information that may not be needed.
    – Thomas Ward
    Apr 22, 2016 at 16:06
  • Fair enough, I am not so familiar with launchpad, comments edited. @ThomasW.
    – Mark Kirby
    Apr 22, 2016 at 16:07
  • 1
    @Stan I edited your answer - there is a likelihood to break the dependencies with manual installed .deb files (hence run apt-get install -f afterwards). Also, you assume users are on as 'root' with your non-sudo commands - added that as well.
    – Thomas Ward
    Apr 22, 2016 at 16:08
  • 2
    @Stan great answer! I edited it to include images, and a little more detail. If you feel I've overdone it, please rollback.
    – Tim
    Apr 24, 2016 at 14:42

All .deb files which you manually install are considered to come from 'third party' locations where the system cannot verify the license on the software. The Google Chrome installer as such originates from Google, a third party, and not the Ubuntu repositories - the warning message here indicates this, but since it can't verify the license terms, it also says it may be non-free. Google Chrome is still OK to use.

The message you see there serves as a warning in the event that you want to make sure it's a 'valid' install or something able to be trusted, and is just a notice that the software doesn't originate from the Ubuntu repositories; it also indicates that some of the software from there may be non-free and may have other license restrictions on it.

It is more or less a way to let you know there may be other things to keep in mind - that the software is not Ubuntu-maintained, or may have non-free license restrictions - before you install the software from that .deb file.

This is not an error - it's a warning message. You can still click "Install" and install the Google Chrome browser or anything else from .deb files at your leisure, as it won't stop you from clicking that "Install" button. (except for if there's dependency issues - that's a different, unrelated issue)

If the new software center isn't working, chances are it's a bug - that message isn't related to it./

Lets go and use the manual method of installing.

In the terminal, we can manually install. I'm assuming you saved the .deb to your user's Downloads folder. Replace "PACKAGE" with the actual filename here.

sudo dpkg -i ~/Downloads/PACKAGE.deb
sudo apt-get install -f

You should also run apt-get install -f after the dpkg -i just in case there's dependencies that need resolved - apt-get is capable of determining the dependencies issues, but dpkg is not.

  • 1
    thank you for your answer but when i click on Install it wont be installed. Apr 22, 2016 at 15:55
  • same here, downloaded deb packages cannot be installed, the install button doesn't do anything
    – Stan
    Apr 22, 2016 at 15:58
  • @ShahramShinshaawh I have updated my answer to indicate that the message you saw isn't related - but how to manually override it and force it to install through the CLI. As well as how to address the dependencies issues.
    – Thomas Ward
    Apr 22, 2016 at 16:05
  • This worked for me with Ubuntu 16.04
    – Subfuzion
    May 5, 2016 at 4:44
  • this is because a lot of repos are still using deprecated SHA1 instead of SHA256 or SHA512 checksums, this issue will persist until all the repos are updated
    – Amias
    May 5, 2016 at 15:51

For me in case of Google Chrome apt-get install -f correctly resolves dependencies only after apt-get update:

sudo apt-get update
sudo dpkg -i google-chrome-stable-...-amd64.deb
sudo apt-get install -f

I have the same issue and this solve my problem
1. change server repository to main
2. update system
3. restart

  • please add more details how to do these 3 steps.
    – TiloBunt
    Sep 1, 2016 at 23:37

I had this problem. It appeared that I've installed 32-bit version of Ubuntu by mistake but I thought that I have a 64-bit one. So when I tried to install 64-bit .deb packages I got this problem but when I tried to install 32-bit .deb packages later they have been installed smoothly.


First you need to open a terminal (Ctrl+Alt+T)

Then type:

sudo apt install gdebi-core

Enter password, then try to reopen app with Ubuntu Software Center.

It works for me


Open the terminal by pressing Ctrl+Alt+T. Type:

sudo apt-get -f install

Press Enter, put in your password.

If it runs with no errors, type:

sudo apt install gdebi-core

Press Enter. After that I was able to use the Software Center, open it and install all the OS Updates.


The simplest which ensures that it can download any dependencies alongside. Which sometimes the gdebi GUI does not download (faced this problem myself).

Install gdebi-core by using the following command

sudo apt install gdebi-core

Then cd in the folder in which your currently your .deb package is on. For example:

cd ~/debs/

Then use this command to install your application.again with example :-

sudo gdebi google-chrome-table_51.0.2704.63-1_amd64.deb

This should download dependencies if needed and will install your app successfully.

  • I tried this on Ubuntu 16.04 LTS ....doesn't work. Jul 19, 2016 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.