2

Recently I have lost the ability to play sound from Flash-based apps like YouTube through the built in speakers on my Ubuntu 14.04 laptop via Chrome. (When I plug into an external monitor with speakers, it works fine.) I know this issue is with Chrome because my internal speakers work just fine for other apps. I have seen many sites on how to fix this problem (it appears to be a "known"), but none of the fixes I have tried have worked for me. Here are the things I have tried so far:

  1. Checked all obvious audio settings (speakers are not muted, youtube is not muted, other sounds from different apps, YouTube sounds come through fine in other browsers like Firefox).

  2. Consulted the internet. Found about a million hits for ways to fix it (all of which are detailed below). Some of the suggestions came from Google themselves. Other suggestions pointed to YouTube videos (smh).

  3. Did an apt-get update; apt-get upgrade.

  4. Cleared cache, browser history, etc. dating back to the beginning of time.

  5. Closed and restarted Chrome.

  6. Confirmed that there are no other plugins competing for the audio like other incarnations of Flash via chrome://plugins.

  7. Uninstalled and reinstalled Chrome.

  8. Tried Chrome Beta.

9.Tried incongnito mode.

Does anyone have any other things I can try? I am getting pretty annoyed by the above not working. Hopefully there is something less obvious that actually will work.

TIA.

1 Answer 1

-1

i was having a similar problem. I ended up purging pulse audio and just sticking with alsaaudio. I got qas mixer to manage the sound card and settings and PNMixer for the tray from software center at this point sound was working again in vlc etc after setting default to analog mixing device (I dont use hdmi I out put through the card to a 5.1 system, if you use hdmi you might set defaults to digital mixing.)

Sound now worked everywhere. If still issues try cutting /.asoundrc to another directory from the home folder and restarting. If no change go here https://wiki.gentoo.org/wiki/ALSA#Soundcard_only_available_for_one_application and see if there are any configurations that are wrong

1
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) Jan 31, 2017 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.