Just installed a fresh official Ubuntu 16.04 Desktop LTS on an Intel NuC5i7.

sudo apt install upstart-sysv; sudo reboot will break my system.

The boot is stuck on a purple screen.

I can access another terminal with Ctrl-Alt-F6. If I switch back with Ctrl-Alt-F6 I get a cryptic error (not sure if it is related):

  • /lib+/init/init-d-script: 12: /etc/rc2.d/S02whoopsie: -c: node found basename: missing operand

I have reproduced it inside a Virtualbox VM, I'm redirected to a terminal login at boot with the following error message:

  • [ 17.012097] systemd-logind[1270]: Failed to start user service, ignoring: Unknown unit: [email protected]

Is it just me? What can I do to fix my system and have a working upstart?

3 Answers 3


Maybe you missed this: With the Upstart package in place and the Systemd one removed, you’ll need to update the Ubuntu system to reflect the changes you’ve made before restart.

sudo update-initramfs -u

don't know if it is possible but you could try to start on recovery mode and restore systemd.

sudo apt-get install ubuntu-standard systemd-sysv
sudo update-initramfs -u
sudo reboot

Hope this can help you

  • Did not get any warning: gist.github.com/mgcrea/5806cd8cee3ecfddab7332c73f5215aa tried sudo update-initramfs -u without luck, still broken. reverting to systemd-sysv does fix it, but no more working upstart.
    – Olivier
    Apr 22, 2016 at 15:15
  • @Olivier how u reverted back to systemd-sysv . I m facing same issue. used the above command but its not working. how to get back to systemd-sysv Aug 17, 2018 at 5:06

Go to the screen after rebooting that offers system choice, select Ubuntu advanced options, select 4.4...upstart, my system started after that and is behaving normally.

  • I also found that I had a confusion among kernels. it had installed 64 bit kernel instead of 32. You can check that with "uname - a". Then I did "sudo apt install upstart -sysv" and "Sudo update -intramfs -u -c". That fixed most of the issues. It does not want to mount some of my drives and the screen is blank and waits for ever. If you just hit "S", it skips mounting and boots the system and even the drives come back.
    – user275173
    Apr 24, 2016 at 16:59

I had something very similar, described in this recent post install systemd-sysv failed

After it aborted the install I entered apt-get -f install in a terminal. It appears to have fixed it, insofar as it allows me to boot to a desktop GUI. It might be worth your trying it, if all else is lost.

  • Unfortunately, apt-get -f install does nothing on my system.
    – Olivier
    Apr 22, 2016 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .