0

I have a peculiar problem. I had a blackberry I used to encrypt the files and now I can't seem to remove the (encryption) password from the card. It always asks for the password when I put the card in the (blackberry) phone.I tried wiping the entire device along with the memory card but only the device got wiped out.:P Now, I want to reuse the card so I brought it over to the Ubuntu OS and I tried to format using disks tool,gparted and even dd command line tool!! but all failed. I can basically view the files on any device and play the media files and access documents and stuff like that. Why am I unable to clear the sd card is a real mystery to me. What kind of black magic is this?!! Or is RIM's encryption really that good! :O

Regards XoitX

  • I tried creating a text file in it and it says read only mode!! And I've tried the slider thing.Nothing is wrong with the slider. @Bruni – Alpha Beta Apr 22 '16 at 14:41
  • Have you checked this askubuntu.com/questions/213889/… – Bruni Apr 22 '16 at 18:11
0

Assuming that you have backed up all the important data and the sdcard is mounted at /dev/sdX and all partitions on the sdcard have been unmounted from your system

sudo dd if=/dev/zero of=/dev/sdX bs=5M count=1

will erase the partition information from the head of the drive and the system will now "see" the drive as unpartitioned and from here your can use any tool you like to create the new partitions and file systems you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.