6

I just upgraded to 16.04 and use ibus to manage multiple keyboard input methods. When I switch between them using my favorite hotkey combination, the icon changes (indicating that has registered), but the actual keys still correspond to US english (or whatever the default system keyboard layout is). How do I make ibus change keyboard layouts?

7

Just ran into this hiccup when upgrading, and input methods always give me hell whenever I upgrade my distribution, so I thought I'd post the answer here.

Go into the preferences interface window (via preferences on the panel menu, or alternatively by right clicking the panel icon), navigate to the advanced tab, and then uncheck "use system keyboard layout". This will stop your default system layout overriding ibus when you toggle between layouts.

0

In my case, I had to remove the additional layouts and then re-add them. It helped.

0

I found that ~/.config/ibus/bus owned by root and user can't access it. There should be IBUS_DEMON_PID maintained by daemon. So change the owner and restart PC to populate the relationship. That helped me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.