I've downloaded and installed Ubuntu 16.04 throught Parallels 11 on my MacBook Pro.

The installation went fine and after reboot I could login and use the graphical interface without problems.

Anyway, the resolution was low and the display aspect ratio wrong, so I installed Parallels Tools as usual to fix these minor issues and activate some of parallels features.

After I installed parallels tools I rebooted my virtual machine and all seemed to be fine (login and unity worked flawless), but after I restarted again unity keeps crashing every time I do the login.

I'm aware this problem (or similar) has already been solved somehow here:

  1. Unity doesn't load, no Launcher, no Dash appears
  2. Parallels (Tools) 9 & 14.04
  3. Unity is broken after Parallels Tools installation in Ubuntu 14.04

but none of these methods worked in my case.

In particular:

  1. Following the accepted solution in 1 did not work since when I launch ccsm from command line it doesn't appear inside graphical interface.
  2. Reading the only answer in 2 I realised that I had no xorg.conf at all (seems the default behaviour now a days), so I tried sudo /etc/init.d/lightdm stop and then X -configure and then I reinstalled Parallels Tools with no luck! (NOTE: I had to launch these commands on a clean install since lightdm did not stop properly after I installed Parallels Tools for the first time).
  3. Using suggested solution in 3 (even after generating xorg.conf as described above) I get an error using gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins saying that DBUS could not connect.

Any ideas?

3 Answers 3



Disclaimer: I've found this "solution" by trials and errors, therefore I can't guarantee it's safe. Use it at your own risk.

Background: when Parallels Tools is installed it copies under /usr/lib/compiz/ a bunch of files with this pattern libprlcompiz_*_*_*_*.so (with digits instead of *). Those are unity plugins and, as it seems, when unity gets loaded the latest version of this plugin is loaded as well.

Now, in my case it happens that unity tries to load libprlcompiz_0_9_12_2.so, which causes the error: Segmentation fault (core dumped).

So my catch was to rename this file and hope that the previous plugin version has no bugs (namely libprlcompiz_0_9_12_1.so). Open a terminal and:

sudo mv /usr/lib/compiz/libprlcompiz_0_9_12_2.so /usr/lib/compiz/libprlcompiz_0_9_12_2.so.backup

Now everything should work fine after login.

I still have three parallels related processes appearing in unity side bar after login (with a question mark as icon), which disappear after a while.

Let me know if this works for you.

  • 1
    Thank you. I had exactly the same problem and your workaround has worked.
    – Ghostrider
    Apr 26, 2016 at 3:09
  • 1
    Great!. You saved me a lot of work. Apr 29, 2016 at 5:05

Turn off 3D acceleration, it will work fine.

  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) May 5, 2016 at 18:44

Just installed an update of Parallels Version 11.2.0 (32581) and I seems to have a new package of Parallels Tools. It does not contain the file libprlcompiz_0_9_12_2.so anymore and added some others. Seems to solve the problem. Unity now starts fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.