11

In order to activate Maple16, I need to install the lsb-core package. However, I cannot find the package in Syanptic Package Manager. I've tried to install it by downloading the .deb file, but when I run sudo dpkg -i /home/foo/Downloads/lsb-core_4.1+Debian11ubuntu6_amd64.deb, the output of the terminal is

(Reading database ... 178439 files and directories currently installed.)
Preparing to unpack .../lsb-core_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-core (4.1+Debian11ubuntu6) over (4.1+Debian11ubuntu6) ...
dpkg: dependency problems prevent configuration of lsb-core:
 lsb-core depends on lsb-security (>= 4.1+Debian11ubuntu6); however:
  Package lsb-security is not installed.

dpkg: error processing package lsb-core (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 lsb-core

How can I install this package?

  • For me, still on 15.10, lsb-core is in the repos. apt-cache depends lsb-core tells me this package has these dependencies lsb-release libc6 and libz1, find and install these too. I can't test it for you, I don't have 16.04. – Mark Kirby Apr 22 '16 at 9:02
  • Here is lbs-relese launchpad.net/ubuntu/xenial/+source/lsb I think you may only need to install this one. – Mark Kirby Apr 22 '16 at 9:05
  • @MarkKirby thanks for your answer. Could you explain me how to install launchpad.net/ubuntu/xenial/+source/lsb. I've download the file and search Google for the last 30 minutes to try to understand how to install .TAR.xZ files, but apparently that's very difficult if you don't know what you're doing (and I don't know what I'm doing). – Hunter Apr 22 '16 at 9:38
  • 1
    There is a .deb file available, open a terminal and run wget launchpadlibrarian.net/233789933/lsb-release_9.20160110_all.deb and it will download to your /home. You can also find it under Binary packages on that page but is is a bit tricky to find. – Mark Kirby Apr 22 '16 at 9:43
  • 1
    Try installing this too wget launchpadlibrarian.net/176607818/lsb-security_4.1+Debian11ubuntu8_amd64.deb and then tell me if the error message changes – Mark Kirby Apr 22 '16 at 9:53
11

lsb-core seems to have been re-added to Ubuntu 16.04 (Xenial Xerus) just now.

2

Out of desperation I've downloaded and installed the lsb-core package for Ubuntu 14.04, see here, and this works because now I can activate Maple.

0

With the newest version of Hamachi (2.1.0-165) "[Hamachi] can now be installed without [the] LSB package."

0

For Ubuntu 16.04, just sudo apt-get install lsb-core worked for me. To check LSB Version, do lsb_release

-1

FYI, for anyone looking for this with Hamachi (or others): Found this:

sudo add-apt-repository "deb http://cz.archive.ubuntu.com/ubuntu trusty main"
sudo apt-get update
sudo apt-get install lsb-core
  • 5
    -1 This is a terrible idea and asking for trouble. You shouldn't mix package repositories of different Ubuntu releases unless you know what you're doing. There are ways to prevent those issues and keep the repository but they're not trivial. – David Foerster May 12 '16 at 8:33
  • This is a terrible idea but may be the solution for some situations, e.g. askubuntu.com/questions/767012/epson-printer-with-ubuntu-16-04 If one is going to try this approach it is better to remove the repository once it is done. – brandizzi Jan 16 '17 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.