4

I just got my brandnew M10 ubuntu edition and i love it. I need webdav accesss on it but couldn't get it working, so i thought if I install Nautilus on the tablet i could get it working as easily as on the PC.

I couldn't find a complete guide on how to install X11 legacy apps on the tablet and can't figure it out myself, so if somebody could link a easy to use guide for the M10 i would be glad.

I already installed the terminal from the appstore to use apt-get but this terminal seems to be restricted...

4

Using apt-get can break your system (no more OTA updates at least, and potentially more breakage) and it wouldn't help you anyway because legacy apps need Libertine/Puritine to run. You would need to enable r/w access to your system partition for apt-get to work at all, but that seems to be strongly discouraged.

There is currently no supported way to install legacy X11 software, but it should all be ok in a few weeks when OTA11 comes out and we get the Libertine GUI app and other tools to make it work.

| improve this answer | |
  • thank you for your answer. This german article link claims that one could install x11 apps on the M10 in a "container" with a terminal and apt-get, are those containers the same like libertine or is this a complete different way? – Freeatlast Apr 22 '16 at 21:54
  • 1
    Yes, from what I have gathered that would be a libertine container. It's true that there are a few command line tools installed (and the preinstalled LibreOffice, Gimp and Firefox are packaged that way), but I didn't get it to work so far and decided to wait for OTA11 (the next update) where it will be fully supported, including a GUI app. – Jens Grivolla Apr 23 '16 at 9:05
  • Here's an interesting discussion including instructions: plus.google.com/101402903185277489519/posts/h1frtNV4Har It seems that sometimes you can just locally install an application in your home directory (so you don't have to mount the system partition r/w), but in other cases you need to properly install things inside a container. I haven't tested it myself yet, though. – Jens Grivolla Apr 28 '16 at 11:14
1

I managed to get netbeans working in the container, it was ok, but Ive been exploring and using apt-get and now I realized I shouldn’t have done that. So I am erasing doing a hard reset here, and will wait for the OTA11

| improve this answer | |
1

https://drive.google.com/?usp=docs_web gives an example of how to install Inkscape in a libertine/puritine container. It worked fine for me and I installed a couple of other X11 packages (PSPP and wavesurfer) the same way. So with a bit of trial and error, it's possible. GNU Octave didn't install successfully though. OTA11 will make life easier, though, I hope.

| improve this answer | |
  • Your link only leads me to my googledrive home folder, maybe you can fix this? – Freeatlast May 22 '16 at 23:08
  • Sure, it's moved to [link](notyetthere.org/installing-more-puritine-apps-on-the-m10 ) – JohnC2016 Jun 2 '16 at 18:22
  • I urge caution though. It worked for some X11 software, but the one I really wanted to GNU Octave, just bricked my M10 tablet on several attempts, forcing me to re-flash it. So now I just await a fully tested Libertine installer. – JohnC2016 Jun 2 '16 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.