There used to be a workaround with enabling suspending and hibernation, which worked for me at 14.04 LTS, but having cleanly installed 16.04 LTS I lost that, and now my computer won't come back from suspend.

I tried the tutorial listed here: http://ubuntuhandbook.org/index.php/2014/04/enable-hibernate-ubuntu-14-04/ to enable hibernation but running

sudo pm-hibernate

Leaves me with black screen and processor running, I cannot restore the system, I can only manually shut it down and run again.

Yet my SWAP is bigger than my RAM (8.5 GB).

So I cannot hibernate nor suspend (the latter I can, but the computer doesn't wake up until restarted).

Please help?

Using Lenovo z50-71, i5 laptop with ATI /Intel hybrid graphics.

up vote 4 down vote accepted

I had similar issue with not waking up after suspending, leaving me with black screen and processor running. There seems to be a bug in linux kernel that Ubuntu 16.04LTS is using. So upgrading the kernel to 4.4.8 solves the problem.

You can download the kernel for your system from here and set up.

Hopefully that solves your issue.

  • It actually did, upgrading to varios other LT and mainline kernels. Not the 4.4.0.22 build though. THanks! – Mookey Jun 1 '16 at 5:54

Adapted from this answer on askubuntu:

Use TuxOnIce kernel with uswsup for suspending

  1. Double check if your swap partition/file is setup correctly in /etc/default/grub; you can do so by checking the location with either cat /proc/swaps or swapon -s; or you could better yet, find out the UUID or label of the swap partition/files(s) and use that:

    tail -n -9 /proc/swaps | cut -d ' ' -f 1 | xargs sudo blkid
    
  2. Edit /etc/default/grub by finding the line with GRUB_CMDLINE_LINUX_DEFAULT=, add your swap partition inside, and save. If you use the UUID, prefix it with UUID= or /dev/by-uuid/.

  3. Add the TuxOnIce stable repository:

    sudo add-apt-repository ppa:tuxonice/ppa
    
  4. Install TuxOnIce kernel & uswsup:

    sudo apt update
    sudo apt install uswsusp linux-generic-tuxonice tuxonice-userui
    
  5. Restart your computer (reboot;)

  • Sorry about that @DavidFoerster , I have fixed the answer. – Enkouyami May 2 '16 at 6:39
  • sudo apt install uswsup linux-generic-tuxonice tuxonice-userui E: Unable to locate package uswsup – CrazySynthax Oct 17 '16 at 18:30
  • 1
    @CrazySynthax it was because I forgot an "s" in the uswsusp package name. – Enkouyami Oct 17 '16 at 22:38

protected by Community Apr 27 '16 at 6:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.