As a fresh new install of Ubuntu 16.04

sudo apt-get install openssh-server

outputs sudo apt-get install openssh-server

Also it is a fress install I could not understand why this happens.

dpkg -l openssh\*

Output is

dpkg -l openssh

If canonical upgrades to 1:7.2p2-4 for openssh-server version I think problem will be solved.

Also there is a screen shot of synaptics package manager

Synaptic package manager

If I mark for upgrade there is a window shows packages to be removed:

Removed

Any help will be appriciated.

  • try to upgrade before : apt-get update && apt-get upgrade -y – monitor35 Apr 22 '16 at 7:49
  • Nothing changes. – akikara Apr 22 '16 at 8:11
  • I don't remember to have had any issue to install it. Can you give us the output of : dpkg -l openssh\* – monitor35 Apr 22 '16 at 8:18
  • Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Architecture Description +++-=========================-=================-=================-======================================================== ii openssh-client 1:7.2p2-4 amd64 secure shell (SSH) client, for secure access to remote m un openssh-server <none> <none> (no description available) – akikara Apr 22 '16 at 8:45
  • openssh-client version is higher than openssh-server. Client version is 1:7.2p2-4 but server version is 1:7.2p2-2. If canonical upgrades to 1:7.2p2-4 for server version. – akikara Apr 22 '16 at 8:47
up vote 4 down vote accepted

I was getting the exact same error.

In the Software & Updates changing the server from my local country to Main server, and also adding the Canonical Partners from the "Other Software" tab helped installing the openssh-server in my case. I am not sure which of the two helped.

  • Changing servers to main server has solved all problems. Thanks. – akikara Apr 27 '16 at 12:30

Try to perform a apt update before :

apt-get clean
apt-get update
apt-get install openssh-server

I was getting the same error and I didn't need to change the server.

I had the same problem. I fixed it by uninstalling the openssh-client and then installing openssh-server.

sudo apt-get remove openssh-client
sudo apt-get autoclean 
sudo apt-get install openssh-server

protected by Community Feb 22 at 15:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.