32

ORIGINAL QUESTION UPDATE 1:

Including Additional Drivers screenshot. I have tried installing both 361.42 and 340.96 and both times, I get a blank screen after restarting.

enter image description here


ORIGINAL QUESTION:

When I install the nvidia driver for ubuntu and then restart, I get a blank screen. I have no tried 2 of the nvidia drivers and both times I get a blank screen.

How do I install the nvidia drivers and not get a blank screen?

Did a google search and it seems I'm the first to encounter this issue since 16.04 has been released:

https://www.google.co.uk/?gfe_rd=cr&ei=6tUZV-rEEuTR8geL_5PABA&gws_rd=ssl#q=ubuntu+16.04+nvidia+blank&tbs=qdr:d

  • I somehow accepted the wrong answer. How do I change it? – oshirowanen Apr 23 '16 at 17:45
  • 2
    If you solved your problem yourself, please answer your own question and accept it. Don’t put the answer in your question or the comments! Send me a message in the comments if you want my up-vote. :-) – David Foerster Jan 24 '17 at 21:07
23

Where/When do you get the blank screen? Is it when the grub menu should appear upon boot, or when the Ubuntu Unity login screen should appear? If it's the latter, try the following:

  1. Add nomodeset on your Ubuntu grub entry. Highlight the entry you use to boot, press e, then add replace

    ...ro quiet splash ...

    with

    ...ro nomodeset quiet splash ...

If that boots to the login screen correctly, press Ctrl + Alt + F2, login, then run sudo prime-select intel. Then reboot and see if that fixes it.

Also, how are you installing NVidia drivers? DOuble-check at nvidia.com if you're using the correct ones.

  • I get the blank screen after the grub menu when I select Ubuntu. The grub screen only appears after the first attempt, I get no grub at the first attempt, the grup screen automatically appears when I restart the blank screen. – oshirowanen Apr 22 '16 at 18:21
  • 1
    Did you try nomodeset? – SteveFromAccounting Apr 23 '16 at 0:41
  • 4
    I did try it, and it didn't work. Little did I know what by setting nomodeset before installing the nvidia drivers removes nomodeset. So this time, I installed nvidia first, then set nomodeset and it worked! Thanks for the help! – oshirowanen Apr 23 '16 at 7:23
  • 2
    Nope, this doesn't work at all. Still a black screen for me :( – starbeamrainbowlabs May 29 '16 at 12:12
  • 1
    Not an expert here, but nomodeset doesn't load video drivers, and those video drivers are probably responsible for enabling dual monitor support. So your attached screen not working makes sense. – SteveFromAccounting Jun 27 '16 at 22:38
6

Here's my solution. I had to pull answers from several locations.

My graphics card is the NVidia GeForce GTX 950.

The first thing I did was download the latest stable NVidia driver from nvidia.com (for me, it was 361.42). I was sure to select the latest stable and certified driver. It's a ".run" file, by the way. Search on how to install .run files if you're not familiar with this.

I then blacklisted the Nouveau drivers according to this post (my steps are below and are slightly different from this post):

Install Nvidia driver instead nouveau

I did all of my work through the virtual terminal accessed by Ctrl+Alt+F1 from the log in screen:

1) Blacklist the modules. Open the blacklist.conf file.

sudo vi /etc/modprobe.d/blacklist.conf

add the following modules to the end of the file:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

Save the file and exit.

2) Remove all the nvidia* packages (note this didn't do anything for me, but it's recommended. No harm done in running it)

sudo apt-get remove --purge nvidia*

3) Update the initramfs disk. Mine was configured to load the nouveau drivers. It takes several seconds. Don't reboot or poweroff!

sudo update-initramfs -u

4) Reboot

5) Stop the display manager and then install.

At the login screen press Ctrl+Alt+F1 again to get into the virtual terminal. Once you are in the text mode, stop the display manager:

sudo service lightdm stop

6) Then, run the installation file (the .run file you downloaded). The installation is well documented and contains lots of useful messages along the way (imagine that!). I did get the error about the pre-install script failing. I continued anyway. I got asked "Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X? Any pre-existing X configuration file will be backed up" I answered "Yes" and continued. I have a 64-bit system and got 32-bit errors. I didn't worry about it and continued. The 64-bit ones installed fine. I got to the end of the installation!

7) Cross your fingers, reboot, and log in. My system FINALLY came up. I hope yours does too!

  • Will this keep working after a kernel update, or will you have to perform some manual steps each time that happens? – Lars Haugseth May 20 '16 at 11:29
  • 1
    Good question - and timely. I recently just installed a new kernel, not thinking. Then, when I rebooted, it came up in a low-res mode (probably 800x600). Logging on just flashed the screen and put me back at the login screen. Then, I rebooted and selected the older kernel and everything was fine. So, I'm not sure what the long term solution to this would be other than fixing the original problem. I guess I will stay on an older kernel for now. – DerWanderer May 23 '16 at 15:10
2

Try to add nvidia ppa ppa:graphics-drivers/ppa and install the lastest 364.15.

That works for me with optimus 860m.

This works only if you have Secure Boot disabled.

  • 1
    just tried it. gave the same problem unfortunately. – oshirowanen Apr 22 '16 at 19:43
  • It also works with Secure Boot, but not if you're using the shim or shim-signed to boot. Instead, you need to use a signed kernel and the signed grub-efi bootloader: sudo apt-get install linux-signed-generic grub-efi-amd64-signed. Also there might be multiple EFI boot entries (even with the same name) and the BIOS might choose the wrong one by default, so you will have to override that in the Boot Selection Menu or in the BIOS Setup. – blubberdiblub Jul 2 '16 at 16:05
2

Maybe you have to blacklist the nvidia drivers at startup. That is sometimes needed by hybrid graphic cards.

  • Edit the file: /etc/modprobe.d/bumblebee.conf and add:

    blacklist nvidia-XXX
    blacklist nvidia-XXX-updates
    blacklist nvidia-experimental-XXX
    

    replace the XXX by the version of the graphic driver. For example 346

  • reboot your computer.

  • This solved it for me (Ubuntu 16.10; Dell XPS 15). It was missing the new nvidia-367 drivers in bumblebee.conf that weren't blacklisted – naisanza Jan 30 '17 at 22:42
1

I solved this issue a different way. I installed 16.04 on a very old computer. I installed the Nvidia legacy driver, and got the blank screen.

I installed Lubuntu to use the LXDE desktop. That is working very well for me.

sudo apt-get install lubuntu-desktop
0

Make sure you have secureboot disabled, I happened to have mine enabled and ignored the warning when I upgraded to 16.04. If you have secureboot on, it will get stuck on gdm or in a black screen.

  • Not sure yet what secureboot is, but does this apply if I did a fresh install of 16.04. I didn't do an upgrade from 14.04 to 16.04. – oshirowanen Apr 22 '16 at 13:13
  • Plus my computer is about 5 years old, I don't think it has secureboot. But I'll have a double check in the morning. – oshirowanen Apr 22 '16 at 14:57
  • 2
    I can't see secure boot in the BIOS. – oshirowanen Apr 22 '16 at 19:43
-2

Try adding the following options to your grub /etc/default/grub config file. You'll need to update grub afterward.

GRUB_GFXMODE=1280x1024x32,auto
GRUB_GFXPAYLOAD_LINUX=keep
  • I think these options only affect Grub, not the operating system that's booted. – starbeamrainbowlabs May 29 '16 at 12:14

protected by Community Apr 23 '16 at 5:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.