35

This question already has an answer here:

I just did a fresh install of Ubuntu 16.04 that I set to log in automatically. When it loads up all I get is the desktop wall paper but not top panel or unity side bar. Previously I was using Ubuntu 16.04 Mate edition and everything worked great. I read this question Ubuntu 16.04 unity desktop environment doesn't load after fresh install but I could not get to a tty screen like the poster in that thread. When I did Ctrl+Alt+F1 all I would get is a blank screen. I've tried switching monitor inputs and going from my nvidia card to the onboard graphics but nothing seems to work. I'm just going to switch back to Mate for now but I would really want to check out what's new in Unity. Thanks for any and all help!

marked as duplicate by David Foerster, Eric Carvalho, Pilot6, Kevin Bowen, muru May 12 '16 at 19:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You can right-click on the desktop, and choose Open Terminal. That's what I did. Then I've removed the compiz configurations and cache as pointed out by @Jonayard, below. – Atcold Nov 14 '16 at 22:19
  • 1
    This should not be set as a duplicate. None of the other solutions worked for me under 16.04. – Jacques MALAPRADE Mar 9 '18 at 9:42
66

Fix compiz problem :

sudo rm -fr ~/.cache/compizconfig-1
sudo rm -fr ~/.compiz

Then try this if your session not loading :

sudo rm -fr ~/.Xauthority
sudo rm -fr ~/.config/autostart

Reinstall compiz

sudo apt-get install --reinstall ubuntu-desktop unity compizconfig-settings-manager upstart

Finally clear the Unity Desktop :

sudo dconf reset -f /org/compiz/
setsid unity

This is how I fixed my problem hope it could be helpful to you.

  • 2
    Cool, I'll try that if I can manage to get a terminal window or drop into a TTY screen so far no luck though. – Hector Apr 27 '16 at 17:11
  • 2
    I think this is exactly the correct workaround. I had the same problem, I tried to use the guest account to log in it seems to be fine. I compared everything between the guest account settings and the root account settings. There is no much difference on compiz settings but Xauthority and autostart are different – ZijunLost Aug 23 '16 at 19:51
  • 6
    sexy answer bro. Solved my problem. – Kaushal28 Aug 27 '16 at 15:32
  • 3
    You sir are a scholar and a gentleman. – MikeJerome Sep 2 '16 at 23:14
  • 5
    You're real gem!! Fixed problem in Ubuntu 16.04. Thank you very much. Mr. Rahman! – Rajnish Sep 16 '16 at 6:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.