19

I just upgraded to Ubuntu 16.04 from 14.04.

When I run System Settings, my CPU usage goes to 100%, and the Settings window always remains in focus. I tried to open System Monitor to kill System Settings, but the focus kept on changing back to Settings. When I click the close button, the current instance of Settings closes, but at the same time a new instance of the window pops up.

The only solution I found was to log out of the system.

Output of apt-cache policy unity-control-center:

unity-control-center:
  Installed: 15.04.0+16.04.20160413-0ubuntu3
  Candidate: 15.04.0+16.04.20160413-0ubuntu3
  Version table:
 *** 15.04.0+16.04.20160413-0ubuntu3 500
        500 http://jp.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     15.04.0+16.04.20160413-0ubuntu1 500
        500 http://jp.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  • 1
    Exact same problem here. xkill does not help either, another instance respawns instantly. – Nicolas Raoul Jun 27 '16 at 5:18
  • I noticed this only happens after launching the Settings dialog and clicking on either "Text Entry" or "Details". Same for you? – Nicolas Raoul Jun 27 '16 at 5:54
  • Is this the same issue: bugs.launchpad.net/ubuntu/+source/activity-log-manager/+bug/… – saji89 Jun 27 '16 at 6:08
  • When started from command line it appears that some libraries are missing: libgnome-desktop-3.so.12: cannot open shared object file: No such file or directory. Which is turn is due to dependencies bugs that hit me when upgrading from 2015.10 to 2016.04: ifupdown : Breaks: systemd (< 228-3~) – Nicolas Raoul Jun 27 '16 at 6:51
  • @saji89: It indeed sounds similar (apart from that page being for 14.04 and mentioning a released fix) – Nicolas Raoul Jun 27 '16 at 6:53
1

This was a bug that has since been patched. The version of unity-control-center shown in your output from apt-cache policy unity-control-center is out of date.

I issued the following commands:

sudo apt-get purge unity-control-center

sudo apt-get install unity-control-center

sudo apt-get install unity-control-center-signon

Note the change in output.

$ apt-cache policy unity-control-center
unity-control-center:
 Installed: 15.04.0+16.04.20170214-0ubuntu2
  Candidate: 15.04.0+16.04.20170214-0ubuntu2

protected by Community Sep 18 '17 at 7:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.