25

Ubuntu Software error This is the error I get when I open the software center. I've tried rebooting and running sudo apt-get update but I see no improvement. It worked earlier but I don't know what went wrong since then. I'm using Ubuntu 16.04 final release on a Dell Inspiron 15R. Any advice will be appreciated. Thanks in advance.

EDIT: The problem magically solved itself without me doing anything special (or maybe inadvertently doing something, I don't know). So I'd still like to get to the root of this.

2

10 Answers 10

18

Just had this problem after using bleachbit to cleanup the system on moving from the beta to the official release. Cleaning out all the cache data also blanked out the software center (re:user533424 above).

It seems to "magically" reappear by anything that regenerates this data. So...

settings>region languages> ... and changing or reinstalling your current language

....also worked for me.

3
  • Makes sense because I had also used bleachbit.
    – Mav14
    Apr 26 '16 at 16:35
  • 6
    I haven't used bleachbit, and this solution doesn't work for me. May 1 '16 at 22:53
  • reboot your system
    – Prabs
    Sep 12 '19 at 13:49
12

Happenes after you used BleachBit with root access and cleaned App cache Data

  1. Open Ubuntu Software Center
  2. Click on updates tab
  3. Click on small refresh button located at the top-left corner
  4. Wait for it

Refer pic for refresh button

Everything will be back to normal enter image description here

4
  • This works like a charm! Don't have to restart or remove/install anything. This is the best option. Jul 23 '16 at 19:49
  • +1 this people, its the only logical best way to make it work. Aug 7 '16 at 21:07
  • 1
    I don't have this icon Sep 1 '16 at 21:17
  • 4
    I have the icon, I did it and nothing changed.
    – Zibri
    Dec 17 '16 at 15:45
7

I think this has to do with the /var/cache directory, at least that is what I suspect based on my own experience.

Workaround that worked for me:

sudo apt purge gnome-software ubuntu-software
sudo apt autoremove
sudo apt install gnome-software ubuntu-software
3
  • So you just reinstalled it?
    – Mav14
    Apr 24 '16 at 23:05
  • Starting Ubuntu Software on 16.04 cause an 'internal error'. Reinstalling it totally fixed it. It upgraded some packages which I presume were the cause of the problem. Nov 18 '16 at 18:38
  • Other fixes did not work on my new Ubuntu 16.04 LTS installation, but the expedient of reinstalling did! kudos Nov 22 '16 at 4:22
3

It works for me. Change Language Support > Regional Formats to English(United States), then reboot your computer. Software center works properly now.

3
  • 2
    Language support is in System Settings. Apr 27 '16 at 16:28
  • Although this might help, it can not be the ultimate solution to change the whole system's locale just to be able to install software through a graphical user interface... I appreciate your answer, it's just that I'm disappointed of the Gnome Devs if this actually solves the problem.
    – Byte Commander
    May 26 '16 at 20:35
  • reboot your system
    – Prabs
    Sep 12 '19 at 13:49
1

Yes, it seems to be a language configuration issue. Ridiculously impossible out-of-the-box glitch, yet there it is in an LTS release. :\

Even if your system is in English already, re-select it in System Settings > Language Support, re-apply system-wide, and reboot. Now the new app store actually functions.

1

I had the same problem. But my problem was not rooted in language setting or anything related to that. My problem was cuased by a program called GoGui; a game of go interface program that can connect to different engines. I found solution to my problem through launchapad post: https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1563155 #28 and #29. So basically the problem was the gogui registers file types of *.xml to x-go+xml which I guess Ubuntu Software tries to open with but can not be found. Deleting /var/cache/app-info/xmls/fwupd.xml and unregistering the the created lines by Gogui in /usr/local/share/mime/globs and /usr/local/share/mime/globs2 solved the problem for me!

0

I got my software center working by changing the language into English. But I can see yours is already in English, so that will probably not help you...

0

I started while installing synaptic-package-manager. Multiple events started appearing, but actual installation did not start. I used bleachbit (as root) a few times, as the installation was on and using sudo apt-get update for every app installation. Unchecked the deletion of apt files from bleachbit. I managed to install synaptic package manager from command line after reboot using sudo apt-get install syanptic-package-manager. Used it to reinstall ubuntu-software. Now the all applications are listed.

0

This problem is pretty annoying and tends to plague me sometimes. But what seems to work is killing the application from the terminal.

ps aux | grep -i gnome-software
kill -9 <replace with PID number>

Then restart Software and hope for the best.

-1

the Ubuntu Software Center on my PC is also showing "No application data found" but that appeared right after I was mounting /var/cache as tmpfs. I've experienced this issue with previous versions of the Ubuntu Software Center as well and therefore decided not to use a tmpfs for /var/cache any longer but I also couldn't figure out how to restore those files... Anyhow as per definition /var/cache is intended for cached data from applications. Such data is locally generated as a result of time-consuming I/O or calculation. The application must be able to regenerate or restore the data. Unlike /var/spool, the cached files can be deleted without data loss. The data must remain valid between invocations of the application and rebooting the system.

Files located under /var/cache may be expired in an application specific manner, by the system administrator, or both. The application must always be able to recover from manual deletion of these files (generally because of a disk space shortage). No other requirements are made on the data format of the cache directories. see http://www.pathname.com/fhs/pub/fhs-2.3.html#THEVARHIERARCHY

Which, in this specific case is not true, since the Ubuntu Software Center won't be working correctly after deleting those files.

Hope that's a good hint for the root cause but may not solve the issue.

2
  • Oh btw. did you try to refresh via the "Updates" tab on the very left side the little refresh button? It worked for me...
    – user533424
    Apr 22 '16 at 11:47
  • I tried doing that, but I didn't see immediate results. I checked back after a couple restarts and it works now. Weird.
    – Mav14
    Apr 22 '16 at 15:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.