7

After upgrading to Ubuntu 16.04, I tried to use the new software center that came along with it, but I found it to have a few issues. One, it didn't detect all the applications I had previously installed and two, whenever I tried installing new software with it, a new icon on the launcher (saying "Waiting to Install") appears, but no progress is made and the icon is stuck on the launcher.

However, I don't encounter any of these issues in the older Software Center. Does anybody know why this may be?

2

3 Answers 3

11

Try installing the old software-center from the commandline:

sudo apt install software-center

Or try installing synaptic

sudo apt install synaptic
3
  • 1
    I faced the same problem today on 16.04.1 LTS. The system prompt on terminal, to install 'software-center' worked fine for me. Nov 27, 2016 at 16:07
  • Me too had the same problem, 'Ubuntu Software' is not working in 16.04 but 'Ubuntu Software Center' is working perfectly fine.
    – NightFURy
    Dec 17, 2016 at 11:35
  • Your suggestion worked @jringoot, I just sudo apt-get intall software-center Mar 12, 2017 at 21:15
4

I resolved this same issue using 'check for updates' thru the 'About this Computer'-->'Details' menu found thru the top right menu area of the desktop.

2
  • Welcome to Ask Ubuntu! Be aware that we value high-quality content here, so a better explanation (or wording) would fit better.
    – EKons
    Sep 5, 2016 at 21:19
  • This worked for me too. After doing "Check for Updates", Ubuntu Software began working for me. Jan 4, 2017 at 1:00
0

Try to download and install the old Software Center from the new Software Center. Just type in the name in the new Software Center, find it and use it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.