I'm attempting a clean install on a new hd on Dell XPS 8900 i7-6700, but installation fails at "Preparing to install Ubuntu" with an error message "ubipartman failed with exit code 10".

I can boot from the usb stick, but installation won't start from there either.

I've tried switching to ACHI, turning the secure boot off and adding 'nodmraid' to cli boot after 'quiet splash' before double dash in various combinations.

Any help or insight?

Pressing Esc or F6 has no effect in UEFI boot. I tried changing

    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash ---  

to

    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash nodmraid ---

in the UEFI boot options, but it didn't help. This seems to be different than the 12.10 ubi-partman case.

I found an answer that fixed it for me in this thread

http://www.linuxquestions.org/questions/linux-hardware-18/the-new-dell-xps-8900-a-4175559854/

When entering grub during installation, I changed the line to

    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash pcie_aspm=off ---

and that did the trick. I followed info in this link

After booting I made the fix permanent by editing the line in grub that starts “GRUB_CMDLINE_LINUX_DEFAULT” and adding the following:

quiet splash pcie_aspm=off

You need to add a trusted source in the bios. Go to security, add a very easy password and then more menu items will appear. Then set your password to nothing when you are finished (important). See if you can boot. They do not tell you this in the install screen. You can also go to legacy, but you need to be in legacy mode (bios) to get a legacy install.

I am on legacy and if I switch to uefi, I will get a no boot disk error. I am not sure why they are not compatible, but that is what it is.

pcie_aspm=off FTW

Thanks Karhu! Your answer worked for me on my Asus X555UB-NH51

For the uninitiated, you can add the pcie_aspm=off flag by highlighting your boot choice on GRUB's boot selector screen. Then press 'e' to display the editor for adding the string to the end of the line. Once added, press F10 to boot with the modified option(s).

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.