9

I have tried different softwares for drawing using my touchscreen (e.g. Gimp or Krita). However, when I touch and drag (to draw a line) what happens is that only the mouse pointer moves from one place to the other, but as I was not "clicking" to draw.

I also cannot use some gestures such as zooming a picture.

I have installed Touchegg, but I'm not sure how to use it and if it can help me solve this problem.

  • While this may not be applicable to your specific touch screen, I used the Gimp with a Thinkpad X60 tablet, which utilizes a stylus, and this worked fine for drawing. – Akiva Jul 12 '16 at 13:00
  • @Dev Thank you, but that's not really a solution to the problem... The touchscreen should work as well as in Windows, and it doesn't. – cinico Jul 16 '16 at 0:06
  • @cinico It is a temporary solution until you can find a real solution. – Dev Jul 16 '16 at 4:28
2

First install touchegg:

sudo apt-get install touchegg

Install the dependencies for the GUI tool (for TouchEgg) using this command

sudo apt-get install build-essential libqt4-dev libx11-6 libx11-dev

Download the GUI touchegg-gce from GitHub. Then:

  1. Change to the directory holding the .zip file.
  2. Issue the command unzip Touchegg-gce-master.zip to extract the file.
  3. Change into the Touchegg-gce-master folder.
  4. Issue the command qmake
  5. Issue the command make
  6. Copy the touchegg-gce file to /usr/bin

Source: How to Configure a Touchscreen on Linux

Under "Touchegg" it shows you how to configure the program, maybe this'll allow you to draw on your touchscreen. I am sorry I am unable to help further as I don't know much about this program.

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Thomas Ward Jul 17 '16 at 20:46
  • Thank you. I was able to install touchegg, as I mentioned. But it is the problem on configuring it correctly that I couldn't solve because I think I did everything correctly, but still can't draw I as explained... – cinico Jul 18 '16 at 17:46
  • Assuming you completed the 6th step, open Touchegg and click "Add", I'm guessing you'll be drawing with one finger so in the Dialog I'd make Fingers: 1, Gesture: hold, Direction: up (but you'll have to make this same motion configuration 4 times for all the directions, and more for diagonals if possible) Action: drag(?) I'm sorry, I would love to test this out but can't; I wanted to try to help seeing as no one else offered a solution. Its worth trying. You could also try changing the Action to "click" and whatnot and see if it works as should. – HelpMeee Jul 20 '16 at 6:12
1

A workaround is to hold down the mouse button while drawing. This gives you the advantage of not clicking accidentally when bumping the screen for example.

  • He's using fingers on a touchscreen, not a mouse. Why use a mouse on a touchscreen? – ipse lute Jul 12 '16 at 16:53
  • @ipselute I know, I'm just saying hold your mouse button down while you're using fingers on the touchscreen. – Dev Jul 12 '16 at 16:54
  • That's a good one!!! Ha, ha, ha! Just use a cheap mouse instead of an expensive touchscreen! Point taken. Akiva used a stylus that worked, i guess it's a problem of touch sensitivity threshold. – ipse lute Jul 12 '16 at 17:02
  • @ipselute you're so sassy – Dev Jul 12 '16 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.