3

I have installed both vlc and libdvd-pkg on my Lenovo E555 ThinkPad. I have also run the command:

sudo dpkg-reconfigure libdvd-pkg

In Ubuntu 15.10 that seemed to work for playing encrypted DVD's, but on my fresh install of Ubuntu 16.04, I just see this when I try and play a commercial DVD

enter image description here

It works flawlessly playing a regular DVD with an MP4 file on it, the problem only seems to occur with commercial DVD's.


In some other answers to this similar question it was suggested to use

sudo apt-get install libdvdread4

and to then run

sudo /usr/share/doc/libdvdread4/install-css.sh

However this dose not work in this case since the install-css.sh file dose not exist in the /usr/share/doc/libdvdread4 directory.

enter image description here


In some other cases it was pointed out that the region for playing DVD's must be set. In my case here in Eugene, OR, USA the region needs to be set to 1 in order to playback DVD's published for the US and Canada. From regionset I see my drive is set properly.

enter image description here


I have now tried an external DVD player and it seems to work fine. This now makes me think that the issue is more of a driver issue.

I have a Lenovo ThinkPad Edge E550 laptop with an AMD A10 processor in it. From sudo lshw -C disk I get the following hardware info for my cdrom:

enter image description here

Currently I have no clue as to where to go from here. Is this a driver issue, or something else?

Any suggestions on how I might be able to fix this?

2

I just install Ubuntu 16.04, the file /install-css.sh doesn't exist,I use a file in a usr/share/doc/libdvdread4 from linux mint partition and copy it to the same folder in Ubuntu and It's work.

Maybe you can look for file in internte and paste the file in the folder of Ubuntu.

usr/share/doc/libdvdread4

And run the: sudo /usr/share/doc/libdvdread4/install-css.sh

  • I gave that a try, when I ran the install-css.sh script it seemed to run, but I got the warning of dpkg: warning: downgrading libdvdcss2:amd64 from 1.4.0-1~local to 1.2.13-0 – Willoczy Apr 22 '16 at 2:29
  • That did not seem to work, this caused the following dependency to not be met You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libdvdcss-dev : Depends: libdvdcss2 (= 1.4.0-1~local) E: Unmet dependencies. Try using -f. – Willoczy Apr 22 '16 at 2:37
  • It is my understanding that since 15.10 libdvd-pkg has replaced the need for using the install-css.sh script. – Willoczy Apr 22 '16 at 16:33
  • I copied the install-css.sh from my Ubuntu 14.04 into my Ubuntu 16.04, and after run it, I can play encrypted dvd. So this technique works – Sulliwane May 2 '16 at 13:30
1

I had exactly the same problems. The solution was 2 parts. Part 1 is to install the Quicktime drivers: -lib and -dvd [use synaptic for this], and to ensure the VLC install is complete and up to date. Part 2 is to ensure your dvd drive can process the blocks [my old dvd drive could not, so I bought a new one]. Now, all problems solved.

  • rob grune, your answer is opaque: Where and how does one install QuickTime drivers for Ubuntu? – Lexible Apr 19 at 23:50
  • install Synaptic. search for everything Quicktime. – rob grune Apr 21 at 8:31
  • Where and how does one install Synaptic for Ubuntu? How does one "search for everything Quicktime?" – Lexible Apr 22 at 4:15
  • are you running ubuntu? you do not see "ubuntu software" icon anywhere? if not, suggest you fresh install ubuntu 18.04. – rob grune Apr 22 at 5:54
  • Yes. Ubuntu 18.10. Yes, however your answer would be improved by being explicit. For example, you could install software using: a deb file, snap, apt, apt-get, or aptitude, the Gnome software installer, one could compile from source, one could install a package from within another program (e.g. CTAN packages, CRAN packages, etc.). Moreover, different versions of the same software may be installed depending on the particular source/method. You should edit your answer to make your directives explicit. – Lexible Apr 22 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.