25

This question already has an answer here:

Ubuntu Server 16.04 is now released.

I have Ubuntu (server) 14.04.4 LTS, but when I try to do a do-release-upgrade it tells me that there are no upgrades available.

  1. Why?

  2. How can I upgrade my server so I get the new awesomeness?


lizzard@lounge:~$ uname -a
Linux lounge 4.2.0-34-generic #39~14.04.1-Ubuntu SMP Fri Mar 11 11:38:02 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

lizzard@lounge:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:        14.04
Codename:       trusty

lizzard@lounge:~$ do-release-upgrade 
Checking for a new Ubuntu release
No new release found

marked as duplicate by Braiam, TheWanderer, Fabby, chaskes, Seth Apr 23 '16 at 14:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    In case anybody comes here wondering about upgrading from 15.10 to 16.04, I found that after running apt-get update and apt-get dist-upgrade on a 15.10 system it tells me: New release '16.04 LTS' available. Run 'do-release-upgrade' to upgrade to it. on login. But doing the same on 14.04 does not say 16.04 is available. – kasperd Apr 22 '16 at 8:38
  • @hichris123 - my question is subtly different, although the first part of my question is answered by the answer you suggest. – David Apr 22 '16 at 20:19
  • It actually answers both questions. – Braiam Apr 23 '16 at 4:02
  • @braiam - My question is different, and that is what I searched for and did not find an answer to. The question you suggest only asks 'how to upgrade?' and not the 'why?' which mine does. The answers do answer the 'why?', but it is not asked. – David Apr 23 '16 at 11:18
  • 2
    "Why is "No new release found" when upgrading from a LTS to the next?" I really don't know what are you reading. The question and answers accurately solve your problem. – Braiam Apr 23 '16 at 12:25
23

NOTE: With Ubuntu 18.04 LTS it is the same with the first point release that is due out late July 2018. The steps below should be the same, but just warning that my experience with the upgrade from 16.04 to 18.04 this time did not go as smoothly. I recommend waiting for the first point release (18.04.1) in July before upgrading.


Like it says in the Release Notes that the LTS upgrades will be enabled with the 16.04.1 LTS point release, in approximately 3 months time.

However, if you don't want to wait, the following command will tell your Ubuntu installation to install the latest devel-release:

WARNING: Make sure that your system is up to date, all applications are running well, and that there are no partition errors. Recommend running fsck on your system from Recovery Mode before upgrading.

For console/text only

sudo do-release-upgrade -d

For GUI interfaces from a terminal window or by using Alt+F2

update-manager -d

which will run the update-manager and show that a newer version 16.04 is available for upgrade. Follow the instructions on the screen to upgrade to Ubuntu 16.04LTS.


NOTES from the upgrade that I have observed:

The upgrade process will disable all of the 3rd party repositories that are in the /etc/apt/sources.list.d/ folder. It also backs up your old /etc/apt/sources.list to /etc/apt/sources.list.distUpgrade. The files will not be deleted but the repository lines contained within the files will be commented out, except for in the sources.list.distUpgrade file. I found that I was not able to remove the comment in front of the repository and have it just work with the apt-get update command. Instead I had to re-add the repositories by either adding them manually to the /etc/apt/sources.list file or by adding them with the add-apt-repository command again.

PlayOnLinux repository is not Xenial compatible yet. If PlayOnLinux is installed, it will update from the Xenial repositories.

EDIT: Google and VirtualBox repos have been updated.

Adding Google Chrome and VirtualBox repositories back will show the following messages during an apt-get update. These have been reported here and hopefully they get updated soon. The applications will still update without any problems.

W: http://download.virtualbox.org/virtualbox/debian/dists/xenial/InRelease: Signature by key 7B0FAB3A13B907435925D9C954422A4B98AB5139 uses weak digest algorithm (SHA1)
W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)

The graphics-drivers repository for Ubuntu that contains the NVIDIA drivers will have to be added back. Simply running sudo add-apt-repository ppa:graphics-drivers/ppa works with Xenial and updated drivers after install. I did need to copy my old xorg.conf file back for my monitors to work properly.

fail2ban had to be purged with my old custom config files. Reinstalled without issue and appears to be working fine.

Other miscellaneous applications needed to be reinstalled. sudo apt-get install --reinstall <application>

Overall, the upgrade went well and feels really stable.


$ cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"
NAME="Ubuntu"
VERSION="16.04 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
UBUNTU_CODENAME=xenial

$ uname -a
Linux terrance-Linux 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:   xenial
  • 1
    and it upgraded with a couple of errors which is exactly why it isn't enabled by default. LTS are intended for, among other things, systems which need to be stable. Errors contradict stability. – Mast Apr 22 '16 at 11:40
  • 1
    @Mast Good point, and I am not disagreeing at all. But, if you're willing to get your feet wet and help out with bugs and stability by reporting them I don't see any problem with it. So far, I have only found one application that I use that needs to be updated to work with 16.04 and I have had to re-add the 3rd party repositories that I use, which really wasn't difficult. – Terrance Apr 22 '16 at 13:48
  • 1
    @Mast - but were they true errors or just warnings ? As with compilers, an upgrade script should (!!) revert and quit if a genuine error is encountered. – Carl Witthoft Apr 22 '16 at 18:23
  • 1
    @CarlWitthoft Actually all I got were warnings. The errors that it was stating was during the kernel removals of my old kernels. For the most part, it seemed to upgrade pretty smoothly. – Terrance Apr 22 '16 at 18:38
  • 1
    @David Give me a little time to re-write my answer and I will post it for you. – Terrance Apr 22 '16 at 20:59
40

The answer is in the Release Notes

14.04 LTS to LTS upgrades will be enabled with the 16.04.1 LTS point release, in approximately 3 months time.

Stability in an LTS release comes first.

  • 1
    This is a first, right? In my experience, usually the release cycle of Ubuntu is bigger, with more alphas and betas, and the zero release is already stable enough. – rpmcruz Apr 22 '16 at 3:12
  • 5
    @rpmcruz Apparently not. – kasperd Apr 22 '16 at 9:11
  • @mikewhatever - you only answer the first part of my question. – David Apr 22 '16 at 20:21
  • @David I have now, tough I really don't think it's a good idea. – mikewhatever Apr 22 '16 at 20:57
  • Good answer, but could do with an explanation to go with "I do not recommend", so that readers aren't just taking your word for it. – Jon Bentley Apr 23 '16 at 9:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.