The software installer just hangs with a ? icon and from command line it says:

dpkg: error processing package google-chrome-stable (--install):
 dependency problems - leaving unconfigured 
Processing triggers for man-db (2.7.5-1) ... 
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ... 
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ... 
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ... 
Rebuilding /usr/share/applications/bamf-2.index... 
Processing triggers for mime-support (3.59ubuntu1) ... 
Errors were encountered while processing:  google-chrome-stable

6 Answers 6


This worked for me (all other methods suggested got me very lost):

Download the package (64 bit):

wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

Install the package, forcing install of dependencies:

sudo dpkg -i --force-depends google-chrome-stable_current_amd64.deb

In case any dependencies didn't install (you would have a warning or failure message for this), you can force them via:

sudo apt-get install -f

Note: Refer to the link above for 32 bit systems.

  • Please share the detail as well. There is not guarantee the link work later. It is always better to put the core of the solution and share the link to the original source for more detail and reference. Apr 22, 2016 at 10:18
  • Ive submitted an edit that just copies the steps from the provided link.
    – Todd
    May 18, 2016 at 15:05
  • 2
    For me, with Ubuntu 16.04, it works with just the first two steps, without 'sudo apt-get install -f'
    – Yu Shen
    Dec 29, 2016 at 0:16
  • Same as @YuShen, neither need --force-depends. May 2, 2017 at 20:27

Simple steps - 1. Search for and install 'Gdebi Package Installer' from ubuntu app store 2. Right click the downloaded Google Chrome .deb file and select 'Open with' and then click 'Gdebi Package Installer' 3. Done! :-)

Gdebi will automatically fetch the missing dependencies for you


Has been answered in the past, here's a reference.

Refer to: This

  • I'd guess so, I'm still on 15.10 and haven't upgraded to 16.04 yet, but I sure can't wait to do so. It's either that or google's newest version of chrome ended up being broken by something Ubuntu updated or vice-versa.
    – Feg
    Apr 21, 2016 at 18:28

This is the answer that worked for me:

Simple steps:

  1. Search for and install Gdebi Package Installer from the ubuntu Software Center.
  2. Download google chrome https://www.google.com/chrome/browser/desktop/
  3. Right click the downloaded Google Chrome .deb file and select 'Open with' and then click 'Gdebi Package Installer'
  4. Done! :-)

Gdebi will automatically fetch the missing dependencies for you.

So I just want to tell exactly what I did:

$ sudo apt-get install gdebi

$ gdebi google-chrome-stable_current_amd64.deb

P.S.: I was in the Downloads folder when I did this.

  1. Download latest version from https://www.google.com/chrome/
  2. Move to the folder that contains the file, via GUI or terminal (like cd ~/Downloads)

Install the package by clicking on it, or via the terminal:

sudo dpkg -i google-chrome-stable_current_amd64.deb

If you have issues, you may have to run:

sudo apt-get -f install
sudo dpkg -i google-chrome-stable_current_amd64.deb

After downloading the .deb package I ran these commands first:

sudo apt-get update  
sudo apt-get install libgconf2-4 libnss3-1d libxss1

and then change the terminal working directory to the downloaded file location
(like cd ~/Downloads) and then install Chrome using this command on terminal:

sudo dpkg -i google-chrome-stable_current_amd64.deb

It worked for me.

You must log in to answer this question.