I can't view any wifi networks after upgrading to Ubuntu 16.04 from 14.04. This issue also occurred when trying to upgrade to Ubuntu 15.10. This is what my network window looks like:

enter image description here

I have Broadcom enabled in the Software & Updates window: enter image description here

Also there is no option for Wifi in the dropdown menu in the top right. The screenshots are from Ubuntu GNOME, but it also doesn't work for standard Ubuntu. How can I enable wifi networks?

Output of lspci -knn | grep Net -A2:

07:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: XAVi Technologies Corp. BCM43142 802.11b/g/n [1b9a:3002]
    Kernel modules: bcma, wl

Output of sudo apt-get install bcmwl-kernel-source:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
bcmwl-kernel-source is already the newest version (6.30.223.248+bdcom-0ubuntu8).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Output of sudo apt-get install --reinstall bcmwl-kernel-source:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/1,515 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 153417 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu8_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu8) over (6.30.223.248+bdcom-0ubuntu8) ...
Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu8) ...
Loading new bcmwl-6.30.223.248+bdcom DKMS files...
Building only for 4.4.0-21-generic
Building for architecture x86_64
Building initial module for 4.4.0-21-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.4.0-21-generic/updates/dkms/

depmod....

DKMS: install completed.
modprobe: ERROR: could not insert 'wl': Required key not available
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.122ubuntu8) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-21-generic

Output of sudo modprobe wl:

modprobe: ERROR: could not insert 'wl': Required key not available

I think its network manager issue. I had same problem with Intel Wireless-AC 7260.

I executed iwconfig - and the card was there but it was down (iwlist scan failed) - so I run these commands to bring it up manually:

sudo ifconfig wlp4s0 up
service network-manager restart

and it appeared in gnome just like a charm.

  • 4
    Yes. This indeed works :) Awesome. But, after suspend, i have to keep doing this again and again. Is there anyway i can, permanently solve this problem?? – crskhr Apr 26 '16 at 7:09
  • 3
    I only found out restarting network-manager is enough - so indeed, I hope someone can help figuring this out since I do not see any errors (cat /var/log/syslog | grep NetworkManager) – Marek Vavrečan Apr 26 '16 at 11:51
  • 1
    i just had to do $ service network-manager restart – Brock Vond Jan 11 at 2:28
modprobe: ERROR: could not insert 'wl': Required key not available

You need to turn off the secure boot.

Secure Boot is a security standard developed by members of the PC industry to help make sure that your PC boots using only software that is trusted by the PC manufacturer

  1. Turn off the secure boot

  2. Remove bcmwl-kernel-source

    sudo apt-get purge bcmwl-kernel-source
    
  3. Re-install bcmwl-kernel-source and the kernel header:

    sudo apt-get install linux-generic bcmwl-kernel-source
    
  4. Reboot

  • What if I am dual booting it with OEM's Windows 10 Operating system? – WhiZTiM May 5 '16 at 1:03
  • 1
    How do you turn off secure boot? – user1603472 May 8 '16 at 19:55
  • 1
    @user1603472 From the BIOS settings – GAD3R May 8 '16 at 20:02
  • 3
    Thanks. But why is this? Why does it take care of the issue and why is there no other way to fix it? – user1603472 May 8 '16 at 20:04
  • 1
    You do not need to re-install bcmwl-kernel-source after you disable Secure Boot. – Pilot6 Aug 14 '16 at 17:41

For me, this command worked:

sudo /etc/init.d/network-manager restart

I used to need this command for my Chromebook running 15.04 whenever it woke from suspend. It came from some thread.

EDIT:

So this is only a temporary solution. To make it permanent, I put it in a script somewhere (for me ~/bin/fixwifi) then symlinked that script to the /etc/rc2.d with the name S06fixwifi.

In other words

Make a script somewhere with this text in it:

#!/usr/bin/env bash
/etc/init.d/network-manager restart

Make it executable with

chmod a+x <scriptname>

where scriptname is the name of the script you just made.

Then symlink it into the startups

sudo ln -s  </path/to/scriptname> /etc/rc2.d/S06fixwifi

GUI-only: this worked for me, though I don't know how.

  1. I am using a Lenovo B570, an older laptop with a minimal Phoenix BIOS and, I believe, a Broadcom 4313. Proprietary wifi works out-of-the-box using my LiveUSB of 16.04. I only lack wifi after installation. So, I figured this is a failure of my hardware configuration.

  2. In order to get the proprietary driver installed and activated (albeit broken as described above) via the Additional Drivers tab, I needed to manually deactivate my wifi hardware via my laptop switch. Only then was the Additional Drivers tool able to apply the change from the default open source kernel wifi driver. Upon reboot, I had an internet connection at the proper speed, but this displayed in Ubuntu networking as an ethernet connection, and thus could not show wifi hotspot. It merely accepted manual input of a wifi profile.

  3. I went into my BIOS. The only thing I can change at all is the wifi switch and the boot order of devices and operating systems. I switch the wifi on and off. Saved. I switched ubuntu from the #1 slot to the #2 slot and my networking card to the #1 slot as if I were setting up a network boot. I rebooted. After a few seconds, the network boot fails, then proceeded to the Ubuntu loading screen as normal. Immediately upon boot, proprietary wifi worked perfectly with 16.04. Could it be a power issue, a networking hardware or BIOS bug? A coincidental repair of unknown origin?

I had the same (with an Apple PowerMac 13" 2015) when I updated to official 16.04 Ubuntu today - with Unity. Before I used the latest 16.04 preview.

So there is IMHO two problems. One is that with the latest 16.04 kernel (4.4.0-21-generic) the firmware (as far as I understand it) makes the Broadcom 43602 WIFI chip not to work when booting initially. After suspend resume or

 sudo rmmod brcmfmac
 sudo modprobe brcmfmac

fixed the issue.

For whom it will interest: Still then suspend and resume didn't work any more as the box resumed automatically after 2-3 seconds. This seems to be a common problem. Description see https://bugzilla.kernel.org/show_bug.cgi?id=101681 . In my place an

 sudo cat > /etc/rc.local <<EOF
 echo LID0 > /proc/acpi/wakeup
 echo XHC1 > /proc/acpi/wakeup
 EOF

did the trick.

for me it was enough to re-install the driver, first restarting the service to get it working

service network-manager restart
sudo apt-get purge bcmwl-kernel-source
sudo apt-get update
sudo apt-get install bcmwl-kernel-source

I was upgrading hp dv4 from 14.04 to 16.04

  • Isn't that pretty much the same as this answer? – David Foerster Aug 14 '16 at 15:00
  • I summarized it, made it more direct and remove all I didn't care of and added the network restart stuff so you can actually get to the point of doing the whole thing also added the specific pc I was using and the specific upgrading I had this is so next guy in my shoes has a direct answer (this is the answer I would love to have found) – Damian kober Aug 15 '16 at 23:03
  • 1
    I'll allow it. ;-) – David Foerster Aug 16 '16 at 10:03

Although, https://wireless.wiki.kernel.org/en/users/drivers/b43 says that [14e4:4365] is not a supported chipset but you can try

$ sudo apt-get install firmware-b43-installer

http://linuxwireless.sipsolutions.net/en/users/Drivers/b43/ it gives even more details. Reboot will be required after the installation.

There also might be some backport tweaks like intel wireless drivers but I'm not sure about.

I know I'm late to the show, but I was able to solve this problem without disabling secure boot by signing the wl module. Secure boot blocks unsigned modules for security reasons.

First, create a key to upload to the BIOS:

openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=Descriptive name/"

Then sign the module:

sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n wl)

Finally, register the key to secure boot. You may need to install mokutil.

sudo apt-get install mokutil
sudo mokutil --import MOK.der

Then restart your computer and you should be good to go.

Source: Could not load 'vboxdrv' after upgrade to Ubuntu 16.04 (and I want to keep secure boot)

protected by Community Apr 23 '16 at 23:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.