1

I wanted to try Ubuntu 16.04 final on a brand new system: A top-of-the-range AsRock Z170 ITX motherboard with i7 6700K CPU and GTX 970 connected via DVI-D.

When I choose to try Linux (not to install it), both in Uefi and in non-Uefi mode, the Ubuntu 64 bit version with Unity desktop shows the background correctly, but then a blinking message box appears saying error. The error message is not very readable because it is blinking, but it seems to say "compiz crashed with SIGILL"

When I try Kubuntu 16.04.0 final 64 bit, the background appears for a fraction of as second and then the screen becomes black and nothing more happens.

When I try GNOME, I read "Nouveau failed to load".

This motherboard only has USB3 ports and no USB2 ports.

The USB key is FAT32 formatted, and is inserted in a USB 3.0 port. The USB key was created with Rufus in Windows.

The motherboard is setup to allocate 1GB of RAM to the integrated graphics, and is set to start up with the NVIDIA GPU rather than with the Integrated GPU.

[ - UPDATE - ] - Thanks for the answers. Xubuntu 16.04.0 worked out of the box. Kubuntu 16.04.0 Live CD worked only with nomodeset, but I could not boot from the installed OS in any way (nor enter recoverymode). So, in the end, the solution for me, was to set "Primary Display" to "onboard" in the UEFI "Chipset settings". As (K)Ubuntu 16.04.0 has got a kernel greater than 4.3, Intel integrated graphics worked with no effort. As my plan for the GTX 970 is KVM GPU-passthrough, I should not use the external GPU at boot.

  • I have been running 16.04 on my Skylake SFF build with an i5, but only using Intel graphics in UEFI mode. Have you tried just Intel. Or installed the proprietary nVidia driver? What is error message? Is this from installer or after you have installed? With nVidia have you tried nomodeset boot parameter? – oldfred Apr 21 '16 at 17:06
3

According to this :

https://bugs.launchpad.net/ubuntu/+source/llvm-toolchain-3.8/+bug/1564156

This bug will be fixed in 16.04.1

All credit goes to Joakim Koed (joakimkoed) who came with a good option.

What you need to do is:

boot with nomodeset (press E after grub is booted and add nomodeset after quiet splash and press F10 (if I remember correctly)) now change to a terminal with CTRL + ALT + F2 or something.

wget http://koti.kapsi.fi/~tjaalton/skl/build2/libllvm3.8_3.8-2ubuntu1.1_amd64.deb
sudo dpkg -i libllvm3.8_3.8-2ubuntu1.1_amd64.deb
sudo reboot

Hope this helps.

2

I have exactly the same problem with Ubuntu 16.04, but with an ASUS Maximus VIII Gene motherboard. I used the same USB key with Xubuntu 16.04 and had no problem trying Xubuntu 16.04. The display functioned perfectly. This would seem to indicate that the problem lies with Unity.

This appears to be a recognized bug that will fixed in the 16.04.1 ISO. https://bugs.launchpad.net/ubuntu/+source/llvm-toolchain-3.8/+bug/1564156

Not the answer you're looking for? Browse other questions tagged or ask your own question.