20

simple (hopefully) question; I have a Dell XPS 13 with a Skylake processor, running Ubuntu 16.04. Some webpages cause flickering (namely Twitch); I have Googled solutions and came across hardware acceleration as an option to fix it, which worked but caused a lot of screen tearing and increased page load times. Any other suggestions on a solution?

  • Did you tried other browsers/versions? PS: previous versions caused the issue? – Valeriy Solovyov Apr 21 '16 at 16:49
  • I did try Firefox. No issue there. Previous versions do this too it seems. – CKlepka Apr 21 '16 at 17:17
17

I had the same issue as you after installing chrome on Ubuntu 16.04 and enabling GPU rasterization in chrome://flags fixed it for me. Hope this helps

| improve this answer | |
  • I tried that (along with some other flags) and it simply moved the flickering to the UI of the browser, as opposed to the web page. But I may reinstall Ubuntu (went back to Windows for now) and attempt JUST that one later on today. I did post this on Chrome's support forum (see link at end of comment). productforums.google.com/forum/… – CKlepka Apr 23 '16 at 15:18
  • 2
    Enabling GPU rasterization seems to somewhat reduce the flickering but definitely not eliminate it - it is still annoying enough for me to not use Chrome – Paweł Duda Apr 23 '16 at 22:25
  • chrome://flags/#enable-gpu-rasterization – Ertürk Öztürk Mar 16 '17 at 18:35
8

According to this discussion, launching Chrome with following flags fixes the problem (it did solve it for me too):

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers
| improve this answer | |
  • What are the respective chrome:flags? – orschiro Jun 3 '16 at 4:26
  • I don't think there are any as of now but I might be wrong. – Paweł Duda Jun 3 '16 at 7:56
  • I have found Override software rendering list to work. – orschiro Jun 3 '16 at 9:45
  • I think this has worked on my Dell XPS 15 9550 also. Thanks a lot! – morhook Aug 25 '16 at 20:56
6

I think the answer is in this post. As the best answer there:

"I disabled hardware acceleration for my browser from

Settings > Advance Settings > System > uncheck the hardware acceleration"

| improve this answer | |
3

After some research, I found a solution to this problem. It is working for me now.

I disabled hardware acceleration for my browser from

Settings > Advance Settings > System and unchecking hardware acceleration

I am using google-chrome-stable Version 50.0.2661.94 (64-bit) on Ubuntu 16.04

If you encounter scrolling lag and screen tearing, try

Go to: chrome://flags/#smooth-scrolling and Enable it.

| improve this answer | |
1

Open a terminal as root and enter this command: "sudo nano /usr/share/applications/chromium-browser.desktop" and scroll down until you get to this line: "Exec= chromium-browser" Then add this two parameters "--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers" click Ctrl+O to save and Ctrl+X to exit.

Then enter this command as root again: "sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf" and add this lines

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Ctrl+O and Ctrl+X.

Open chromium and write to address bar: "chrome://flags/" and enter.

Enable-zero-copy
Enable Override Software Rendering List
Enable Display 2D List Canvas

Finally open chrome settings and click on:

"Use hardware acceleration when available"
| improve this answer | |
0

I'm on a Dell Inspiron 7559 and have had the same problem on and off for some weeks. I've tried all of the possible solutions I've found (most of which are mentioned above) in various configurations. Some stopped the tearing and flickering for a while or to some extent, but it always seemed to start again.

Some of the solutions actually broke my os (when I changed the xorg file data).

In the end, I switched to using Firefox as my main browser and admitted defeat.

(Edit): My issue seemed to stem not from Ubuntu but rather from the Nvidia drivers installed with Bumblebee.

| improve this answer | |
  • "I gave up and used a different browser" isn't all that helpful for others trying to solve the issue. If nvidia driver/bumblebee was causing your problem, perhaps you could have solved the problem by disabling them? – Zanna Feb 26 '17 at 7:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.