28

I installed Ubuntu 16.04 (dual boot with Win 10) and it doesn't login after. I upgraded from Ubuntu 15.10 via update-manager

https://youtu.be/MrgPYvoVJfA

I have tried old workarounds for previous versions, like:

  • dpkg-reconfigure lightDM
  • chown user:user .Xauthority
  • chmod 666 .Xauthority
  • chmod a+wt /temp
  • mv .Xauthority smth
  • apt-get install ubuntu-session
  • Reinstalling Nvidia Drivers

Any suggestions appre

  • Reset Unity configuration. Howto: askubuntu.com/questions/17610/… – user532996 Apr 21 '16 at 14:29
  • @Squirrel , sorry(( but doesn't help unity --reset – Jasorgho Apr 21 '16 at 20:02
  • 2
    They keep marking these as duplicates, but the old solution doesn't work. I wiped my system because i got fed up and learned it has to do with 3rd party driver issues along with secure boot. Still havnt figured it out yet though. Reported a ton of bugs, were not alone so im hoping its fixed soon. – user383919 Apr 23 '16 at 3:28
  • 1
  • 1
    Which kernel are you using? I got the problem when I was using kernel 4.6.0-rc5. Thanks. – Xiaodong Qi Apr 29 '16 at 5:39
32

I was in the same situation as you.

I did not reinstall nvidia drivers but remove it.

sudo apt-get purge nvidia*

And it worked.

  • 3
    I did the same, and it worked. But, you know, this is not the final solution if one wants to use a second monitor with the support of nVidia cards! – Xiaodong Qi Apr 29 '16 at 5:37
  • 1
    doesn't work for me – Jasorgho May 2 '16 at 6:26
  • You saved my day in November :) – Jacob Vlijm Nov 5 '16 at 15:13
  • This solution worked for me, somewhat. It solved my immediate problem, but it isn't really a final solution to the problem. I also still can't run gdm3 with this change, but lightdm now works. The real problem seems to be an incompatibility between the new kernels and the nvidia drivers (which worked fine for me before I did the upgrade). I find it sad that this wasn't better tested before it was released, and that it still hasn't been fixed yet. – Tom Karzes Nov 9 '16 at 23:14
  • This needs to be higher. Happened to me on two very different systems with nvidia cards while dist-upgrading to 17.04 Zesty. Watch for flickering and black screen after login to see if the graphics driver is the issue. First the purge, then the reinstall of the latest nvidia from 17.04 (nvidia-375) remedied the issue. In case of an Optimus Prime laptop, installation of nvidia-375 nvidia-prime was sufficient. – emk2203 Apr 3 '17 at 9:30
8

On all my systems (all had the same problem) the solution was:

  • Switch to console using Ctrl+Alt+F1
  • Login to text console (your username is enough if your system only has one user. otherwise you will need root user or sudo)
  • rm /home/*/.Xauthority
  • reboot
  • 1
    This helped me (thanks), but it's not what the OP asked (he listed that he already did mv .Xauthority smth – Carlo Wood Dec 3 '16 at 2:18
  • @smth The difference is that the OP only moved away the .Xauthority of one user... – Daniel Alder Dec 4 '16 at 11:05
  • This seamlessly worked for me, without resorting to other suggestions that involve uninstalling or reinstalling components. – matt Aug 17 '17 at 17:45
  • 1
    This is the correct answer – Derek Feb 22 at 19:40
3

I ran into the same problem on my upgrade to 16.04 from 15.10. I recalled that during the upgrade, there was a prompt regarding UEFI Secure Boot options. I checked my BIOS settings and sure enough, Secure Boot was set to "Windows Only". I selected "Other OS" from the list (your options may be different) and booted normally. All fixed.

Have not seen any other mentions of this fix so hopefully this will help.

  • I'd like to confirm that it fixed my problem too. Was upgrading a brand new Dell Precision from 14.04 to 16.04 and going into setup I disabled the Secure Boot and it worked. – Salketer May 20 '16 at 9:43
1

I have this problem to. This problem reason is the new Unity match with 4.4.0 kernel version, and your kernel version same as 4.2.x now You have 2 solution for this problem:

  1. temp: install another desktop env same as gnome,lxde,or etc...
  2. or update the kernel.

for run the command before or after loop ctrl+alt+F1:

for check kernel version: send this command

$ uname -a 

and fore update kernel :

http://ubuntuhandbook.org/index.php/2016/01/how-to-install-linux-kernel-4-4-in-ubuntu/

for install other desktop env googling about your desktop env.

0

I just tried Nuno's idea.. Negative for me.. still stuck in the login loop on Console-7.. But, able to log in via console 1 (TTY1).. I also ran into this back when i went the route of 12.10 to 13.x (both), and it landed in the same loop.. Only workaround I could find, was using an old "Installed" software list from Synaptic, doing a fresh install of 13.04, and also doing the same when i bumped up to 15.04. , getting Synaptic loaded 1st, and then reading in the old software list.

  • just tried another idea, and this one WORKS! Log in via TTY1.. Now, enter the following: [code] sudo mv .Xauthority .xAuthority.old [/code] reboot, and it worked! – Stephen Griswold Apr 22 '16 at 19:21
  • Apparently, I missed a step.. It also requires re-installing LightDM from scratch.. [code] sudo apt-get purge lightdm ; sudo apt-get install lightdm -y [/code], as well as removing all of the nvidia drivers... (insert head hung low..) – Stephen Griswold May 11 '16 at 20:15

protected by Community Apr 24 '16 at 6:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.