6

I've got a problem where my mouse cursor keeps disappearing when my session times out. I log back in and it's invisible, though I can still move it around the screen and click things. I'm in Lubuntu 15.04 and I've tried...

  1. reading as many answered questions as I can find
  2. installing gdm (says something is in use by another program and can't be installed)
  3. Using unclutter to switch mouse on and off (can't find a command that toggles the mouse
  4. Switching into the login screen and back (ctr-alt-f2 and ctr-alt-f7)

System reboot is the only solution I've found and it's quite onerous. Any assistance would be appreciated!

  • I would first install a supported release of Ubuntu, such as 14.04, 15.10 or 16.04, which is going to be released some time on the 21st (tomorrow/today). – TheWanderer Apr 21 '16 at 1:28
4

I have stumbled on this odd bug with a Lubuntu 16 on an Acer Aspire D250. Searching for a fix I found this workaround: pressing Ctrl-Alt-F1 and then Ctrl-Alt-F7 makes the cursor reappear. Works on my system.

  • Yes, it works for me too, but is there a short script or command that could bring back the cursor without doing all this? – Yan King Yin Dec 29 '18 at 7:54
3

I found this looking for the solution to the same problem (this is still happening on Xubuntu 16.04, so updating to a supported release does not solve this issue). I don't know how to prevent this, but I can reliably recover the mouse cursor without rebooting. Open the display manager (Super + P) and make any change you want (change the screen resolution, then change it back. This brings the pointer back whenever a change like this is made. I took this one step further : you can use xrandr for this and map this to a keyboard shortcut. For my laptop I ended up setting Ctrl+Alt+Left arrow to run

xrandr --output LVDS1 --rotate left

and then Ctrl+Alt+Down runs

xrandr --output LVDS1 --rotate normal

so I can quickly rotate left then back to normal and bring the cursor back very easily. Still annoying, but easily overcome.

  • For me, it is the use of Xrandr that made the cursor disappear in the first place... – Yan King Yin Dec 29 '18 at 7:56
1

I have one installation of 14.04 with exactly this behaviour. Don't know why, but workaround as follows.

  1. Bring up a terminal, Ctrl+Alt+t
  2. Hit return in the terminal window and the mouse pointer reappears.
  • while in the terminal, typing xrefresh also seems to help – someoneb100 Jun 21 '16 at 19:55
1

I just came across this issue (Lubuntu 16.04), and found an answer that worked here.

The Fix:

I added this ppa with:

sudo add-apt-repository ppa:oibaf/graphics-drivers && sudo apt-get update

And then updated xserver-xorg-video-intel with:

sudo apt install xserver-xorg-video-intel

This seems to have fixed it for me.

Alternative:

According to the bug report, this was fixed in xserver-xorg-video-intel - 2:2.99.917+git20160325-1ubuntu1.1, so you might find that simply updating the package with sudo apt install xserver-xorg-video-intel works. You can see which packages will be installed with the following command:

  ~ $ sudo apt-cache madison xserver-xorg-video-intel
xserver-xorg-video-intel | 2:2.99.917+git1609021930.ebc066~gd~x | http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 Packages
xserver-xorg-video-intel | 2:2.99.917+git20160325-1ubuntu1.1 | http://gb.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
xserver-xorg-video-intel | 2:2.99.917+git20160325-1ubuntu1 | http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

protected by Community Aug 24 '16 at 13:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.