4

Snap packages are failing to launch the UI complaining of

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version

I've purged the Nvidia drivers to see if the Open Source ones would work, but with no luck. The packages that I have attempted to install have opengl as a listing in the yaml file. OpenGL seems to be working in other aspects of the system so I don't believe it to be an issue with the system.

  • Your might be better off here – Videonauth Apr 20 '16 at 19:18
  • 1
    Could you tell us exactly what you were trying to do when you got that error? This way folks will be able to help you solve your issue. – David Planella Apr 20 '16 at 19:20
  • Sure, though I'm not sure what I can add to the comment above. When I try to launch ubuntu-calculator-app.calculator, or ubuntu-clock-app.clock from the command line the above occurs. These are installed via the snap utility. I am upgrading a laptop with integrated Intel graphics to see if it has the same issue. – SomKit Apr 21 '16 at 1:08
  • That already helped, thanks. Knowing that you got the error from launching ubuntu-calculator-app.calculator gives enough context to start looking at it. – David Planella Apr 21 '16 at 18:06
  • Thanks David, Small update. The Intel gpu doesn't display the error in the console, but the application fails to launch all the same. These 3 computers are all recently updated from 15.10. Could it be something wrong with the upgrade process? – SomKit Apr 21 '16 at 18:18
1

I'm curious if you downloaded the calculator/clock snaps from the store? or did you package those locally? I'm assuming from the store, if so, it would be interesting if you could try to package those locally and sideload them. You can find them from lp:snappy-desktop-examples

Also here's an interesting link on the topic of nvidia gpu and failing to load Problems with libGl, fbConfigs, swrast through each update?

  • Thanks for the response Keivn, On my main development box (15.10 upgraded to 16.04 in during the beta). I tried both ways, from the store and from lp:snappy-desktop-examples. Both experience the same issue. However after attempting to run these apps on a computer without a Nvidia GPU the application fails to load all the same. However it doesn't generate the errors above. I'm about to run a fresh install on my secondary laptop (Also with an Nvidia GPU) I will update the thread after testing both store and local compiled versions. – SomKit Apr 22 '16 at 12:42
  • Also I used However too many times in the above, please mentally remove one of them. I was attempting to write this and get the kids to school. – SomKit Apr 22 '16 at 13:44
  • Fresh install exhibits the same result from the store. Its very odd, I've seen images of it working on other machines. can we do tracebacks in snaps like we can for non-snap packages? – SomKit Apr 22 '16 at 15:53
  • Same problem for me. Fresh install from store. Using nvida GPU with binary drivers. In my Intel box in my job it works ok, but in home is not. – Alejandro Vera Apr 27 '16 at 3:51
  • Same problem for me too. It doesn't work with Nvidia/binary blob, but works well with Intel... – Roberto Jan 4 '17 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.