There doesn't seem to be a chromium (or Google Chrome) port available in Ubuntu Touch (OTA10.1, bq M10). Does one exist, or are there any plans to have one (even without touch / small screen optimizations)?


The system browser in the phone/tablet images is based on the Chromium Content API, and so is roughly the same experience as one would have with Chromium.

If you wish to use Chromium as a legacy X11 app, you should be able to install it inside the legacy apps container with Libertine, in the same way that Firefox/Libreoffice are available.

Google does not provide generic ARM builds of Chrome, so the proprietary Chrome browser version will not be usable.

| improve this answer | |
  • Thanks. I'm mostly interested in having access to Chrome/ium extensions, and being able to link sessions to my Google account. The built-in browser seems very basic, and doesn't seem to have any extension mechanism (or much configurability). – Jens Grivolla Apr 20 '16 at 18:15
  • I'm looking into Libertine, but it doesn't look easy. The instructions at wiki.ubuntu.com/Touch/Libertine mention problems when Puritine is installed. Also, according to your answer in askubuntu.com/a/623311/532550 it looks like I would need to try to get it all working in a chroot. Any additional hints before I completely mess up my tablet? ;-) – Jens Grivolla Apr 21 '16 at 11:16
  • You don't need to do anything special to enable Libertine on the M10. The Ubuntu image there already comes with it installed. That is how Firefox/LibreOffice work there. Libertine/Puritine is the way to go. You should just be able to open the Libertine app, and either create a new container, or install chromium into an existing container. Then go to the Legacy Apps scope to launch Chromium. – dobey Apr 21 '16 at 13:50
  • To add to your reply, I just learned on #ubuntu-libertine (Freenode IRC) that things are not quite ready yet: "the Libertine GUI app itself is not installed on the M10 by default. proper integration of user-installable X apps is scheduled for OTA11 in a few weeks time" – Jens Grivolla Apr 21 '16 at 15:10
  • It seems that your answer is the best I can hope for until OTA-11 comes out, so I'll accept that. Thanks again. – Jens Grivolla Apr 23 '16 at 9:19

You can use the command line tools to install applications in a libertine container. First you create a container in the writable part of the file system. I used the instructions here


The intsructions also tell you how to make a desktop file so it appears in the apps scope. I successfully installed emacs this way.

If you try to do this in the terminal app, you will run into problems due to lack of permissions. The easiest way around this is to start the ssh server with

sudo android-gadget-service enable ssh

Then run

cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys
eval $(ssh-agent)
ssh localhost

Now you can follow the instructions and set up your libertine container and install applications. This script automates the process (I haven't tried it):


| improve this answer | |
  • Mind you, I just tried this and it's not working with chromium for me. Other apps are fine so something about chromium is not playing nice with libertine. – Paul Bryan Apr 30 '16 at 9:09
  • I have tried it also, but chromium doesn't work so far. – Jens Grivolla May 9 '16 at 16:14
  • Have same experience, Firefox is okay but chromium segfaults for some reason. Do not know how to debug yet. FF is like 4x slower (2000 vs 8000 octane) than built-in browser. I expect chromium to be about the native speed which should make it usable for running anything chromebooks can. – grandrew Jun 30 '16 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.