1

I'm using Ubuntu 15.10. I work in an office of about 10 computers (all of them running Windows 7). I had a problem with my computer so I had to re-install Ubuntu from scratch (same version, same configuration, same all). Before that, I could:

  • Browse the network and see all the computers with no problems
  • Access shared files from those computers
  • Prevent my computer from showing up in the network (I didn't really do anything, it simply worked like that from the beginning).

I never configured anything samba-related before, everything worked out of the box. After re-installing, I can no longer access shared files. It keeps asking for credentials, even though they are all public and I never had to enter no credentials. No matter what credentials I enter, it doesn't work. No computer here is password protected.

So I looked around, and then installed system-config-samba hoping it would give me a GUI to configure it (?). Didn't work at all, but with this tool something changed because now my computer shows up in the Windows network, which I really don't want.

I then tried to remove all samba-related stuff trying to re-install everthing. So I did:

apt-get purge samba samba-common
apt-get autoremove

Here's a log of what it removed:

Start-Date: 2016-04-20  11:48:31
Commandline: apt-get purge samba
Purge: samba:amd64 (4.3.8+dfsg-0ubuntu0.15.10.2), system-config-samba:amd64 (1.2.63-0ubuntu6)
End-Date: 2016-04-20  11:48:39

Start-Date: 2016-04-20  11:50:54
Commandline: apt-get purge samba-common
Purge: samba-common-bin:amd64 (4.3.8+dfsg-0ubuntu0.15.10.2), samba-common:amd64 (4.3.8+dfsg-0ubuntu0.15.10.2), nautilus-share:amd64 (0.7.3-1ubuntu5)
End-Date: 2016-04-20  11:50:57

Start-Date: 2016-04-20  11:53:39
Commandline: apt-get autoremove
Remove: python-crypto:amd64 (2.6.1-5build1), apturl:amd64 (0.5.2ubuntu9), libaio1:amd64 (0.3.110-1), python-samba:amd64 (4.3.8+dfsg-0ubuntu0.15.10.2), python-dnspython:amd64 (1.12.0-1), tdb-tools:amd64 (1.3.8-0ubuntu0.15.10.1), python-tdb:amd64 (1.3.8-0ubuntu0.15.10.1), python-libuser:amd64 (0.60~dfsg-1.2), samba-dsdb-modules:amd64 (4.3.8+dfsg-0ubuntu0.15.10.2), apturl-common:amd64 (0.5.2ubuntu9), libuser1:amd64 (0.60~dfsg-1.2), samba-vfs-modules:amd64 (4.3.8+dfsg-0ubuntu0.15.10.2), python-ldb:amd64 (1.1.24-0ubuntu0.15.10.1), attr:amd64 (2.4.47-2)
End-Date: 2016-04-20  11:53:43

But, it's still working! (I have no idea why or how). Everything's the same... Nautilus still shows me the computers in the network, my computer keeps showing up in the network, I'm still unable to access shared files because of credentials.

So I'm completely lost. ALL I want is:

  • To access shared files (and printers) in my Windows network
  • For my computer to not show up at all in the network.

edit

Using sysv-rc-conf I disabled the services: smbd, samba-ad-dc, nmbd and the computer still shows in the network!

  • For anyone looking for a solution, read Morbius1's post in this thread. He gives a temporary solution to mount the Windows shares until this is fixed. Worked great for me. ubuntuforums.org/… – Nahuel Apr 22 '16 at 13:44
0

It was a bug.

http://www.ubuntu.com/usn/usn-2950-2/

Simply updating the packages (after they submitted the fix) fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.