0

Ubuntu 14.04.4 --- MAAS 1.9.1+bzr4543-0ubuntu1 (trusty1)

I have a Machine that PXE Boot and getting the console messages below

Start PXE over IPV4
Booting under MAAS direction
..........
....Bunch of Lines....
.....................
Starting Load Fallback graphics devices ..............[OK]
Starting Load Fallback graphics devices ..............[fail]  ----> This is the Only Fail
....................................
.............
..............
Ubuntu 14.04.1 LTS
sjc-os-controller1 login: Cloud-init v. 0.7.5 running 'modules:config' at .......
Generating Locales 
.........
Generation Complete
...........
....Bunch of Lines....
...............

Then the PXE boot machine/node powers off

No Node present under MASS GUI under Nodes 0 Nodes | 0 Device

MAAS --> Nodes --> Add Machine If i try to add machine with its MAC Address ..... i then get status:(=Failed Commissioning)

Qs: Is there a Log that i can look into to check the root cause and fix the failure and commission nodes in MAAS.......Thank you

0

Logs can be found here /var/log/maas/maas.log The documentation for automatic discovery describes the process that should happen:

With nodes set to boot from a PXE image, they will start, look for a DHCP server, receive the PXE boot details, boot the image, contact the MAAS server and shut down.

It looks like the server was able to connect to the DHCP server and receive a boot image but wasn't able to communicate back so make sure you have configured your Cluster Controller correctly and have added an SSH Key.

  • Cool.... Thank you.... There no messages in /var/log/maas/maas.log for the machine/node that i PXE boot...but when i add Machine with MAC in MAAS ...i tail the maas.log below Error when checking power state: ('UNHANDLED', 'Unknown Error [ahs-maas-1:pid=576:cmd=PowerQuery:ask=9e]') Unable to determine power state. [ERROR] Power state could not be queried: unknown url type: nuova [ERROR]: Failed to refresh power state: unknown url type: nuova DHCP looks ok ......maas.lease_upload_service: [INFO] Uploading 1 DHCP leases to region controller. – aavam Apr 20 '16 at 17:38
  • To keep things tidy just update your question with this new information along with what Power Type you are using and confirm you have added a SSH key. – A Dark Divided Gem Apr 20 '16 at 18:03
  • SSH keys are added for the user that i use to login to Ubuntu....Used Cisco UCS Manager and the errors previously reported...Also used for testing purpose wake-on-lan option and it timed out – aavam Apr 20 '16 at 19:16
  • Sounds like a networking issues, does the node you PXE boot contain more than one network interfaces as this could complicate things? Double check the Cluster Controller can communicate with the Region Controller and they have been configured to meet the network requirements – A Dark Divided Gem Apr 20 '16 at 21:50
  • yes the PXE node has two interfaces eth0 on a different VLAN and eth1 which is on the same VLAN as eth1 of MAAS.....Although the network requirement looks ok b/w Cluster-Region controller but i am getting error in cluster.d log 2016-04-19 14:35:08-0700 [Uninitialized] Region not available: Connection was refused by other side: 111: Connection refused. (While requesting RPC info at 192.168.120.135/MAAS/rpc). What steps can i take to confirm if both the Cluster and Region are working fine....Currently the only zone that i have is the default...... – aavam Apr 21 '16 at 16:05
0

Some time ago I had to deal with servers having the same interesting feature/bug. Two network interfaces that were recognized as eth0 and eth1 in BIOS, switched their positions when booting to Linux. I mean an interface that was eth0 in BIOS became eth1, and eth1 – eth0.

You could leave the interface eth1 (which you said is on the same network as MAAS) and disable eth0 in BIOS. If there's no option in BIOS for switching off eth0, then you'll have to boot into some Live Linux distro and check the order of NICs.

Or you just try switching cables and see if that helps. If it does, then you do have a problem with NIC ordering and you have just solved your problem :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.