26

This question already has an answer here:

Since I upgraded to the latest version of Ubuntu, I cannot install the Java OpenJDK package needed to compile Android custom ROMs. When I run sudo apt-get install openjdk-7-jdk, the following error appears:

Reading package lists... Done Building dependency tree        Reading
state information... Done Some packages could not be installed. This
may mean that you have requested an impossible situation or if you are
using the unstable distribution that some required packages have not
yet been created or been moved out of Incoming. The following
information may help to resolve the situation:

The following packages have unmet dependencies:  openjdk-7-jdk :
 Depends: openjdk-7-jre (= 7u51-2.4.6-1ubuntu4) E: Unable to correct
 problems, you have held broken packages.

How do I fix this problem?

marked as duplicate by Anwar, Zanna, Eric Carvalho, TheWanderer, muru Nov 19 '16 at 15:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

56

had the same problem too.. but i solved it with these commands:

sudo add-apt-repository ppa:openjdk-r/ppa  
sudo apt-get update   
sudo apt-get install openjdk-7-jre  
22

The one I did on 16.04 was:

For OpenJDK 8.X

sudo apt install openjdk-8-jre

For OpenJDK 9.X

sudo apt install openjdk-9-jre

Note: There was no openjdk-6-jre nor openjdk-7-jre for me on Ubuntu 16.04. Also there is NO need to install Oracle JDK (Actually OpenJDK is much better than Oracle one for me).

0

Some feedback with 16.04... If you are installing as part of a "software script" package, you always have to check which version of Java the programs support first.

For example, using openjdk-8-jre (newer version) on the install script.

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install openjdk-8-jre

Not the answer you're looking for? Browse other questions tagged or ask your own question.