8

I have just unboxed my all-new BQ Aquaris M10 Ubuntu Edition and started it for the first time. The device comes with Ubuntu 15.04 pre-installed. While playing around, I was unable to find any setting menu to add new users to the device. One of the main reasons for my decision to wait four years for an Ubuntu powered tablet was to have all users use their own system account.

Update: I have added a Terminal app from the Ubuntu store. I opened a root console and tried

# adduser USERNAME --ingroup phablet

This is what happens:

Adding user `USERNAME' ...
Adding new user `USERNAME' (1002) with group `phablet' ...
useradd: cannot lock /etc/passwd; try again later.
adduser: `/usr/sbin/useradd -d /home/USERNAME -g phablet -s /bin/bash -u 1002 USERNAME' returned error code 1. Exiting.

Error code 1 for useradd command says Can't update password file according to http://linux.die.net/man/8/useradd

So, how to add and edit user profiles on the tablet?

1

To add users via the gui :

go to the System Settings (the cog icon) -> User Accounts

If you want to add users via the cli:

sudo adduser USERNAME --ingroup phablet

If you still have problems:

check the permissions of the password file: ls -l /etc/passwd

they should be -rw-r--r-- and belong to root:root

you can fix this with chmod to change permissions and chown to change owners. For info on how to use those commands postfix --help to see thier options.

  • Thanks for the comment. However, this is not what I'm looking for. As you can read in my question, I have already tried out the common ways to add a new user. So, there is no User Accounts option in the system settings. All you can find there is an Accounts option, which manages Online Accounts for web applications only. adduser doesn't work either, as it throws the error message I've quoted above. And yes, /etc/passwd has -rw-r-r- rights and belongs to root:root. So everything seems to be fine here. – Bunjip May 3 '16 at 8:04
  • maybe your sudo is not working properly. You can test this by running sudo whoami this should ask you for your user password and then print 'root' If you can't sudo its possible you haven't set a password for your user account. do this by running passwd – Amias May 3 '16 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.