3

Problem Case: Dual booting with Ubuntu (efi/gpt scheme) over Windows (efi/gpt scheme) and My HP pavilion is booting directly to Windows 10.

Details:

Previously installed Windows 10 with UEFI, fast start-up, secure boot enabled.

Later installed Ubuntu (GPT partition scheme for Uefi computers and chose Install Ubuntu alongside Windows)

Installation was successful and after a restart, Computer booted successfully into Ubuntu.

But Ubuntu was unable to access Windows (C drive partition), and suggested to disable fast-startup, so I disabled Fast start-up in Windows. After shutdown and power up, computer is booted directly to Windows 10. Tried many times, but every-time unable to choose OS.

strangely, EasyBCD showing Windows 10 as the only installed OS.

Enabled fast start-up in Windows 10 again but in vain.

Did a boot repair using Ubuntu Live USB [as explained here]

Ran these commands (one by one)

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

after third command it gave error as 'no boot-repair found'

This was never a case with Ubuntu over Windows 7.

Is it because Windows 10 is installed with efi/gpt scheme?

What about following combination (Dual boot with Ubuntu over Windows 10). Which of these cases is best for dual booting to prevent this problem.

  1. Windows (MBR scheme) and Ubuntu (MBR scheme)
  2. Windows (efi/gpt scheme) and Ubuntu (efi/gpt scheme) [my problem case]
  3. Windows (efi/gpt scheme) and Ubuntu (MBR)
  • First, disable fast startup. It doesn't make a worthwile difference anyway, and it needs to be off for a working dual-boot setup. Second, EasyBCD purposefully ignores Linux. What you need is to have the right boot device in BIOS. Enter your BIOS at startup, choose ubuntu, let it boot from there. Than you'll get grub to choose windows or ubuntu. – emk2203 Apr 20 '16 at 8:10
  • Ok, I disabled fast startup, still booting directly to Windows & there is no option in BIOS to choose Ubuntu to boot..Bios>System Configuration>Boot Options>Uefi Boot Order>OS boot manager is the top selected device. – user532405 Apr 20 '16 at 8:45
  • Your third command line should have been sudo apt-get -y install boot-repair && sudo boot-repair. Your boot-repair was never run. Run it with sudo. Then reboot and choose boot order sequence at boot with F8 or F12 , whatever your laptop says. Choose ubuntu. – emk2203 Apr 20 '16 at 8:49
  • After changing the third command, Terminal is still throwing the same error "E: Unable to locate package boot repair" – user532405 Apr 20 '16 at 9:33
  • You didn't install it? I see now that this step is missing from you lines. A ppa just adds the packages available. You need to install it with apt install boot-repair before running the third line. I use sudo apt update && sudo apt install boot-repair in one line to avoid this issue. – emk2203 Apr 20 '16 at 9:35
0

In my case I had to disable Secure boot in the BIOS first. Install Windows 10 and then Install Ubuntu.

| improve this answer | |
  • I tried to disable secure boot but nothing helps.But you disabled it prior to any OS installation and I am doing it now. – user532405 Apr 20 '16 at 9:35
  • Yes, change the secure boot BEFORE installing any of the OSes. – warhansen Apr 20 '16 at 9:40
  • @warhansen that does not make a lot of sense. just installing a bootloader after disabling secure boot should do it as well. – LittleByBlue May 3 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.