0

I've recently tried to install the latest stable kernel which is 4.4.6 and when the kernel was compiled and I brought the kernel up and running, there was a problem and the wireless driver (MT7630e 802.11bgn) seemed not working. Then I tried to reinstall it using the source code and the output was like:

make -C /lib/modules/uname -r/build M=/home/devin/Desktop/MT7630E-release linux wireless driver/rt2x00 modules make[1]: Entering directory /home/devin/linux-4.4.6' arch/x86/Makefile:148: CONFIG_X86_X32 enabled but no binutils support make[1]: *** No rule to make targetlinux'. Stop. make[1]: Leaving directory /home/devin/linux-4.4.6' make: *** [all] Error 2 cp -v firmware/*/* /lib/firmware/ ‘firmware/BT/mt76x0.bin’ -> ‘/lib/firmware/mt76x0.bin’ ‘firmware/Wi-FI/MT7650E234.bin’ -> ‘/lib/firmware/MT7650E234.bin’ cp rt2x00/mt7630e.ko /lib/modules/uname -r/kernel/drivers/net/wireless/ cp btloader/mt76xx.ko /lib/modules/uname -r`/kernel/drivers/net/wireless/
depmod

modprobe: ERROR: could not insert 'mt7630e': Exec format error
modprobe: ERROR: could not insert 'mt76xx': Exec format error

I was trying to figure out what seems to be a problem, based on the output I guessed the final loadable modules that got compiled, they were not matched with the arch or something, or it could be because the proper options were not set while compiling the kernel.

Now what I need to know is to get to know the process of loading LKMs when modprobe is invoked or something's wrong with the kernel?!

the arch of the kernel: x86_64

0

/home/devin/Desktop/MT7630E-release linux wireless driver

The command make doesn't like spaces in the name. Please try renaming the folder to:

MT7630E-release

Or to:

/home/devin/Desktop/MT7630E-release_linux_wireless_driver

Or something with no spaces. Then try the make, sudo make install sequence again.

2
  • I tried what you said but it throws me this one: ../rt2x00/rt2x00config.c:273:27: error: ‘struct ieee80211_conf’ has no member named ‘max_sleep_period’ autowake_timeout = (conf->max_sleep_period * beacon_int) - beacon_diff; – Devin Hudson Apr 20 '16 at 6:10
  • I guess there was something wrong with the source code whereas I downloaded github.com/benjarobin/MT7630E.git this one it worked well. – Devin Hudson Apr 20 '16 at 6:21
0

Yes, you have to replace all the missing files of this folder:

https://github.com/benjarobin/MT7630E

with this one

https://github.com/neurobin/MT7630E/tree/e7130a42f8198cbf503a5a307175073c078bf340

following the same procedure of the last one. with my ASUS N751JK on Ubuntu 14.04.4 kernel 4.2.0-35-generic work fine !!! thank you  Devin Hudson

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.