0

Having an issue with an Ubuntu 14.04 server running a Samba share.

This server was configured by another person, and has been running for a few years now. I was transferring files from a hard drive yesterday, but when I went to check to see if they had finished transferring, I was disconnected from the share. I decided to just close the folder, and reopen it, but it isn't visible at all.

Normally under Network (both Windows and Linux), the share appears under Windows Network, then Guest. However, Guest is no longer visible.

I did restart the server, but this did not fix the problem.

I did restart the services:

service smbd restart
service nmbd restart

This did not fix the problem.

I did check /var/log/samba/log.nmbd, and got this from it:

[2016/04/19 06:26:07.759121,  0] ../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
  find_domain_master_name_query_fail:
  Unable to find the Domain Master Browser name GUEST<1b> for the workgroup TCR-GUEST.
  Unable to sync browse lists in this workgroup.

I've yet to find a threat that addresses this problem.

One other thing to note; the server has no GUI, only a command line interface.

Update 1:

I forgot to mention, when I restart, or stop and start smbd, I get this:

stop: Unknown instance:
smbd start/running, process 3781

I also get this from testparm -s:

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
WARNING: Ignoring invalid value 'share' for parameter 'security'
Error loading services.

Update 2:

Here is the smb.conf file:

[global]
workgroup = WORKGROUP
server string = %h server (Samba, Ubuntu)
wins support = yes
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d

####### Authentication #######
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:*   >%n\n *password\supdated\ssuccessfully*
pam password change = yes
security = share
map to guest = Bad User

I appreciate any answers that you would have.

  • do you see any share using this df -h – bhordupur Apr 19 '16 at 19:48
  • It is better if we could see your smb.conf – bhordupur Apr 19 '16 at 19:55
  • you can have a look here linuxquestions.org/questions/linux-networking-3/… – bhordupur Apr 19 '16 at 20:01
  • @bhordupur I'm trying to post the smb.conf file, but it will not format right in the question. I tried to add it here, but it doesn't fit all of it. Is there a simple way to add it to the question where I don't have to manually format the entire config file? Also, I understand the firewall bit, but not the OS firewall that is mentioned there. Is there a place that explains that in greater detail? – Caturday Saint Apr 19 '16 at 20:54
  • its better if you could add them to find the problem else it is hard to say anything? – bhordupur Apr 19 '16 at 20:59
1

Try commenting out the line

security=share

from your smb.conf file. That's what it took to get mine working again. Don't forget to restart smbd and nmbd afterwards.

| improve this answer | |
  • Thank you, this did fix the problem. The funny thing is, the person that set up the server, showed me this setting, and stated that it needed this line to avoid password requirements. It had been working for over a year, but just decided to not work yesterday. Thanks again. – Caturday Saint Apr 20 '16 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.