I always have to type in

 sudo modprobe snd-hda-intel 
in order to get my sound card to work I have already tried the solution to append snd-hda-intel to /etc/modules with

 sudo sh -c 'echo "snd-hda-intel" >> /etc/modules' 

The line is added accordingly into the file, anyways that does not seem to work. Please give advice.

edit: I did run

 dmesg | grep snd 
--> no result.

afterward i run

 sudo modprobe snd-hda-intel 
and then I did run
 dmesg | grep snd 
--> see output


[  162.098807] snd_hda_intel 0000:01:00.1: Handle VGA-switcheroo audio client
[  162.134560] snd_hda_codec_realtek hdaudioC0D0: ALC892: SKU not ready 0x598301f0
[  162.134978] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC892: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[  162.134982] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[  162.134985] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[  162.134988] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[  162.134991] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[  162.134993] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[  162.134997] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x19
[  162.134999] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[  162.135002] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a

  • Try dmesg | grep snd to figure out why it doesn't get autoloaded. Commented Apr 19, 2016 at 17:30
  • @mikewhatever - i have edited my answer to add the requested information. What should i do next?
    – T3n3d0s
    Commented Apr 24, 2016 at 8:26

3 Answers 3


After attempting an "oss4" audio install, I lost audio, and reverting my mistake, did not recover the audio.

Needed to "manually": modprobe snd-hda-intel every boot....to get audio on Ubuntu

Until I found that the driver had been put in a blacklist.... on the oss4 attempt.

grep snd-hda-intel /etc/modprobe.d/*
/etc/modprobe.d/oss4-base_noALSA.conf:blacklist snd-hda-intel

moved the "oss4-base_noALSA.conf" away from the "/etc/modprobe.d"

sudo mv /etc/modprobe.d/oss4-base_noALSA.conf /root

and now, do not need to manually "modprobe snd-hda-intel" after every boot....to get audio on Ubuntu

Hope it helps...

Similar to How can I ensure the `snd-hda-intel` module is loaded on startup?

  • yep! this works for me. even just commenting the line from grep in that file made it work (and survive a reboot) Commented Feb 12, 2021 at 0:33

I had issues getting sound to work after upgrading to Ubuntu 20.04.

modprobe snd_hda_intel commands failed to load module:snd_hda_intel. 

The module was missing. I installed it via:

uname -r (note kernel version)
apt-get install linux-modules-extra-5.4.0-56-generic

This installed the missing module, after this, I could module:snd_hda_intel and everything worked!


Please turn off secure boot using mokutil. Mine had the same problem but got it working by disabling secure boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .