After upgrading to 16.04 from 15.10 it was running smoothly for about one week, then it started getting random crashes and freezes and now all the windows borders disappeared. I would include a screenshot but the keyboard shortcut for screenshots doesn't work.

Launcher is missing, and the global menu/ top bar is also missing. Right now my firefox window is maximized to the top and fills the screen like if I had pressed F11 to run it fullscreen. None of the keyboard shortcuts work.

Can't open a terminal using Ctrl + Alt + T. I finally managed to get a terminal open and ran unity --debug and this is the result. [opened the terminal using ctrl+space to open synapse, apparently that works and also copying in terminal and pasting firefox also works]

unity --debug
unity-panel-service stop/waiting
unity7 stop/waiting
unity-panel-service start/running, process 2515
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
/usr/bin/compiz (core) - Info: Loading plugin: core
/usr/bin/compiz (core) - Info: Starting plugin: core
[New Thread 0x7ffff3638700 (LWP 2588)]
/usr/bin/compiz (core) - Info: Loading plugin: ccp
/usr/bin/compiz (core) - Info: Starting plugin: ccp
[New Thread 0x7fffeb20e700 (LWP 2590)]
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : unity
[New Thread 0x7fffeaa0d700 (LWP 2591)]
/usr/bin/compiz (core) - Info: Loading plugin: composite
/usr/bin/compiz (core) - Info: Starting plugin: composite
/usr/bin/compiz (core) - Info: Loading plugin: regex
/usr/bin/compiz (core) - Info: Starting plugin: regex
/usr/bin/compiz (core) - Info: Loading plugin: commands
/usr/bin/compiz (core) - Info: Starting plugin: commands
/usr/bin/compiz (core) - Info: Loading plugin: resize
/usr/bin/compiz (core) - Info: Starting plugin: resize
/usr/bin/compiz (core) - Info: Loading plugin: place
/usr/bin/compiz (core) - Info: Starting plugin: place
/usr/bin/compiz (core) - Info: Loading plugin: move
/usr/bin/compiz (core) - Info: Starting plugin: move
/usr/bin/compiz (core) - Info: Loading plugin: snap
/usr/bin/compiz (core) - Info: Starting plugin: snap
/usr/bin/compiz (core) - Info: Loading plugin: session
/usr/bin/compiz (core) - Info: Starting plugin: session
/usr/bin/compiz (core) - Info: Loading plugin: imgpng
/usr/bin/compiz (core) - Info: Starting plugin: imgpng
/usr/bin/compiz (core) - Info: Loading plugin: compiztoolbox
/usr/bin/compiz (core) - Info: Starting plugin: compiztoolbox
/usr/bin/compiz (core) - Error: Plugin 'opengl' not loaded.

/usr/bin/compiz (core) - Info: Loading plugin: mousepoll
/usr/bin/compiz (core) - Info: Starting plugin: mousepoll
/usr/bin/compiz (core) - Info: Loading plugin: vpswitch
/usr/bin/compiz (core) - Info: Starting plugin: vpswitch
/usr/bin/compiz (core) - Info: Loading plugin: workarounds
/usr/bin/compiz (core) - Info: Starting plugin: workarounds
/usr/bin/compiz (core) - Error: Plugin 'opengl' not loaded.

There is one error of opengl plugin not loading. Is that the problem?

  • 1
    @jokerdino: This question is similar to that question, but the one marked duplicate is 14.04, while this question is for 16.04. I've tried everything in that thread with no success for 16.04, and others have had similar problems. That's probably why this question was created.
    – jvriesem
    Commented Nov 1, 2016 at 20:13
  • @jvriesem, the accepted answer of this question is present in each of the other questions and they all share the same problem. If none of these solutions work for you, please ask a new question.
    – jokerdino
    Commented Nov 2, 2016 at 10:39
  • @jokerdino: Sure enough. Sorry, I missed that this question had an accepted solution!
    – jvriesem
    Commented Nov 2, 2016 at 14:28

2 Answers 2


I found the answer from this thread (https://askubuntu.com/a/717860/25131)

  1. Alt + F10 and then open terminal from the menu that appears
  2. then type ccsm in to the terminal.
  3. in there search for unity plugin and enable it.

It asks several questions because enabling it conflicts with another. After enabling it the Unity launcher and menu bar should appear.

  • 1
    Hint: I recommend to not go for ccsm. The point is that unity really comes with its own stuff; and you would actually need to first install ccsm. You better go with the "duplicated" answer and reset the the .config/dconf user file.
    – GhostCat
    Commented Jun 22, 2016 at 6:29
  • Jager's advice worked, but it's a bit of a harsh reality as you need to reconfigure your whole environment.
    – gone
    Commented Jul 3, 2016 at 20:25
  • not enough information to actually do this.
    – user5245
    Commented Jan 28, 2017 at 16:29
  • alt+f10 does nothing. ccsm is not found. ubuntu 16. Commented Feb 5, 2019 at 23:07

I do notice that once in a while compiz would freeze up on me and cause the environment to freeze also. Maybe try removing it to see if that changes anything? edit: im talking about the gui manager

  • Is there any way to do that with the terminal, because that's the only thing that I can get to open
    – prab4th
    Commented Apr 19, 2016 at 16:35

Not the answer you're looking for? Browse other questions tagged .